Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,943 Members 52,920 Now Online
XDA Developers Android and Mobile Development Forum

Battery/Charging Issues (Nexus 4)

Tip us?
 
Cooldood2012
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Question Battery/Charging Issues (Nexus 4)

I am having problems with my Nexus 4.
History, replaced screen after phone was knocked out of my hand, probably damaged battery while trying to remove it, but everything worked once it was back together.
Screen broke again, and while working on that, I noticed the battery had swollen so ordered a replacement of eBay.
All back together now, but.
1 Phone does not state "charging" when connected to AC or USB charging, although the battery icon has the lightning bolt in it and the %charge does not drop while messing with the phone.
2 Phone does charge using wireless, but slowly, and status swaps back and forth between charging and not charging and the % will move from e.g. 40% to 35% as it says charging or not charging.
3 USB works for connection to PC.
I charged the new battery overnight, wirelessly. It got to about 90%, so slow charging, but seems to work. Phone is usable, everything seems to work. I connected it to PC and was able to use Nexus Root Toolkit to backup, the reset the phone, no change in charging behavior.
Booting into safe mode made no difference either. So it seems it is not software/firmware/apps that are causing the problem?
I guess next step is to open it up again and remove and remake all connections and check contact posts? Should I order a third battery? Or a new motherboard?
I searched here, but could not find anyone with the same problem.
Any and all help appreciated. Thanks in advance, guys.
 
Cooldood2012
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Opening and rechecking connections and coating with contact cleaner has made no difference.
Phone typically needs Volume Down and Power button pressed to get it to start, then Power Button to select start option, then seems to run okay.
Battery still not reaching 100% charged, generally 70-80% after a full night off, using wireless (my Nexus 5 charges happily on same charger).

Ordered a cheap battery from China, not really expecting that to be the problem, but no other clues or suggestions for now.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes