Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,554 Members 36,260 Now Online
XDA Developers Android and Mobile Development Forum

[Q] HD Voice

Tip us?
 
Firegrill
Old
#1  
Senior Member - OP
Thanks Meter 24
Posts: 118
Join Date: Aug 2011
Location: Ottawa
Default [Q] HD Voice

Do you need to enable something for hd voice?
Does it need 3g or will it work with wifi?

Nexus 4
Rom: Paranoid Android
Kernel: Hells Doctor/Moob
 
scream4cheese
Old
#2  
scream4cheese's Avatar
Senior Member
Thanks Meter 853
Posts: 2,991
Join Date: Jun 2011
Location: New York, NY
Quote:
Originally Posted by Firegrill View Post
Do you need to enable something for hd voice?
Does it need 3g or will it work with wifi?
Do you mean HQ (High Quality) voice?
My Devices

LG Nexus 5 16GB
HTC One M8 GPE 32GB
Asus Nexus 7 (2013) 16GB


 
Firegrill
Old
#3  
Senior Member - OP
Thanks Meter 24
Posts: 118
Join Date: Aug 2011
Location: Ottawa
Quote:
Originally Posted by scream4cheese View Post
Do you mean HQ (High Quality) voice?
http://en.wikipedia.org/wiki/Wideband_audio

Nexus 4
Rom: Paranoid Android
Kernel: Hells Doctor/Moob
 
polzovotel
Old
(Last edited by polzovotel; 22nd March 2014 at 09:26 PM.)
#4  
Senior Member
Thanks Meter 46
Posts: 117
Join Date: Jun 2011
Quote:
Originally Posted by Firegrill View Post
Do you need to enable something for hd voice?
Does it need 3g or will it work with wifi?
First, it is not relevant 3G or Wifi - HD Voice is a cell support feature, it is not using you data connection.
Nexus 4 supports HD-VOICE: http://en.wikipedia.org/wiki/List_of...using_HD_Voice

Anyway, there is not a simple answer. Your provider needs to support HD Voice on Nexus 4 (in particular.)
Orange Israel, for example, support HD Voice on Nexus 4 with Android 4.2.2 at maximum. If you upgrade to 4.4x
it will stop working and there is no option to enable it.

BTW, just saw that in local forum we have an official reply from LG:

"Officially and Originally, Nexus4 does not support the AMR-WB even though it was worked well in previous version.

AMR-WB has not been supported by H/W but by S/W and it makes performance issue during PTCRB test that’s why we cannot pass the PTCRB test with enabling AMR-WB.
But, Nexus4 needs a PTCRB certificate for Global market and we decided to remove the AMR-WB feature from the S/W side."
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes