FORUMS

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

Camera problems

3 posts
Thanks Meter: 0
 
By matteoas, Junior Member on 16th February 2014, 10:42 AM
Post Reply Subscribe to Thread Email Thread
A friend of mine gave me a Nexus 4 with a camera problem. He said that, after ota upgrade to the last version of kitkat, camera stopped to work ("camera not connected" error). Both front and back camera don't work, and led flash too. I've tried every version of android stock, cyanogenmod 10 and 11, and franco kernel too. I've open the phone and unmounted every piece: nothing looks wrong. Maybe logical board? Or a defective back camera? But led flash and front camera don't work too. Maybe a software problem? Thank you
 
 
16th February 2014, 03:35 PM |#2  
badboy47's Avatar
Senior Member
Thanks Meter: 958
 
Donate to Me
More
Try reverting back to 4.2.2; see if that fixes it. If not you might have to open it to make sure the wires for the camera is connected.

Sent from my Nexus 4 using Tapatalk
16th February 2014, 06:13 PM |#3  
nexuspur's Avatar
Senior Member
Thanks Meter: 118
 
More
Try to flash the Google stock ROM with a toolkit then it should work

Gesendet von meinem Nexus 4 mit Tapatalk
16th February 2014, 10:32 PM |#4  
OP Junior Member
Thanks Meter: 0
 
More
But, as I already wrote, i've tried to flash every N4 android version (with unified toolkit, of course), and I've unmounted every piece and everything looks ok. I don't think the back camera is broken, as front camera and led flash don't work too.
17th February 2014, 11:43 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Do u think that if back camera doesn't work, the front camera and flash led are off? I tried now without back camera, now without front, and i've the same error.
17th February 2014, 05:14 PM |#6  
nexuspur's Avatar
Senior Member
Thanks Meter: 118
 
More
can you share your topical setup rom+kernel...?

---------- Post added at 05:14 PM ---------- Previous post was at 05:07 PM ----------

try also to delete your app data off the camera (gallery) in app settings or try another camera app in the playstore and check it again. if nothing helps i think something inside your device is broken
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes