Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,064 Members 41,164 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Says Bootloader is locked when not. Bricked Nexus 4?

Tip us?
 
jackinho24
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 15
Join Date: Mar 2011
Default [Q] Says Bootloader is locked when not. Bricked Nexus 4?

Around a week ago everything was force closing on my N4 so I decided to reboot it, when I did it got stuck in boot loops. Because of this I went to wipe the data and cache so I could flash a Rom but when I did all my data from my SD partition had disappeared. This has happened to me before and the way I solved it last time was to unroot and flash back to stock using the Nexus 4 toolkit. However when I went to do that this time it said my boot loader was locked so I couldn't complete the task. So then I unlocked the bootloader which apparently is successful but when I refresh the bootloader it seems to be locked again. Over the last week I have tried sideloading zips, force flashing, unrooting, unlocking the bootloader and all this on both a mac and windows toolkit.

When researching this problem I only could find one thread which resembled my problem on xda however it was about the Nexus 7 and the person ended up sending it back to Asus. Would be great if someone good respond, thanks!

(Also my device is a Rooted UK 16gb if that helps)
 
jd1639
Old
#2  
jd1639's Avatar
Recognized Contributor
Thanks Meter 3055
Posts: 9,085
Join Date: Sep 2012
Location: Minnetonka, MN
It sounds like your emmc flash memory is bad. Not being able to lock or unlock the bootloader is a sign of that. You should warranty the device.
The Following User Says Thank You to jd1639 For This Useful Post: [ Click to Expand ]
 
lolcakes203
Old
#3  
lolcakes203's Avatar
Senior Member
Thanks Meter 37
Posts: 176
Join Date: Jan 2013
Location: Toronto
I agree. I faced a similar problem on my Optimus 2X. It started with occasional bootloops, and last week it got to the point where it was boot-looping after every boot w/ force closes, missing data, and e2fsck did nothing, because the fixed errors came back within hours. Definitely sounds like your memory chip has called it quits.
Devices:
LG Optimus 2X P990
LG Nexus 4

LG Optimus 2X:
ROM: Tonyp TheROM Build 26 New Bootloader
Kernel: Kowalski Kernel M1 New Bootloader 2.6.39.4 W/ RAM Hack
Bootloader:ICS Bootloader
Recovery: TWRP 2.6.0.0 For New BL
Baseband: 1035.21

Nexus 4:
ROM: Stock 4.4.4 W/ Root (Xposed, GPU Drivers, Dalvik/Bionic Patches)
Kernel: Matr1x 14.0 W/ GPU OC
Bootloader: Stock Bootloader (Unlocked)
Recvoery: PhilZ Touch CWM-Based Recovery
Radio:Radio (1.03)
The Following User Says Thank You to lolcakes203 For This Useful Post: [ Click to Expand ]
Tags
nexus 4 bricked, nexus 4 can't unroot, nexus 4 locked bootloader
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes