Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,054 Members 40,766 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Charging on AC but shows USB

Tip us?
 
faddyie
Old
#1  
faddyie's Avatar
Senior Member - OP
Thanks Meter 45
Posts: 348
Join Date: Nov 2011
Default [Q] Charging on AC but shows USB

Initially my phone started to charge slow since a week with the original charger and cable came with N4 in the box. I googled and got to check in the battery settings as if it shows AC or USB. Its showing USB and charging quite slow. I flashed yesterday factory image after deleting everything but still it shows as USB.
One more thing, when i connect the charger it shows AC and after a few seconds it says USB and sticks to it.
After connecting the charger it acts as the charger is powered on and off 3-4 times whereas i dont turn the power off/on.

Any help.
Nexus 4 MAKO
 
faddyie
Old
#2  
faddyie's Avatar
Senior Member - OP
Thanks Meter 45
Posts: 348
Join Date: Nov 2011
Quote:
Originally Posted by faddyie View Post
Initially my phone started to charge slow since a week with the original charger and cable came with N4 in the box. I googled and got to check in the battery settings as if it shows AC or USB. Its showing USB and charging quite slow. I flashed yesterday factory image after deleting everything but still it shows as USB.
One more thing, when i connect the charger it shows AC and after a few seconds it says USB and sticks to it.
After connecting the charger it acts as the charger is powered on and off 3-4 times whereas i dont turn the power off/on.

Any help.
Anyone...?
Nexus 4 MAKO
The Following User Says Thank You to faddyie For This Useful Post: [ Click to Expand ]
 
TJ_Ahluwalia
Old
#3  
TJ_Ahluwalia's Avatar
Senior Member
Thanks Meter 93
Posts: 220
Join Date: Jan 2012
Location: Chennai
Happening to me too!! Please help someone.

Sent from my Nexus 4 using XDA Premium 4 mobile app
 
senthilrameshjv
Old
#4  
senthilrameshjv's Avatar
Senior Member
Thanks Meter 214
Posts: 818
Join Date: Nov 2011
Location: Chennai
Quote:
Originally Posted by TJ_Ahluwalia View Post
Happening to me too!! Please help someone.

Sent from my Nexus 4 using XDA Premium 4 mobile app
Happens to me as well. I even got a new USB cable from Flipkart and tried with other chargers. Same thing happens. I googled enough for this and find no feasible solutions.
Hit thanks if it helped

Nexus 4 - Velocity - ART - Velocity/Hells Creed Kernel - Banks Minimal Gapps
Neo V - Resurrection Remix Rom
Tab - Micromax Fun Book talk

Only Rooting makes a smartphone 'SMART'. Until then, its just a PHONE. - Self

Get Dropbox and get 500Mb space for both of us - https://db.tt/ZQG4kcVe
 
faddyie
Old
#5  
faddyie's Avatar
Senior Member - OP
Thanks Meter 45
Posts: 348
Join Date: Nov 2011
It seems to be a hardware issue. but the weird things is it initially recognizes as AC but then after few seconds change to USB.
Further, after pinning the cable, phone reacts as the power is on-off-on-off 3-4 times.

Please help.
Nexus 4 MAKO
 
faddyie
Old
#6  
faddyie's Avatar
Senior Member - OP
Thanks Meter 45
Posts: 348
Join Date: Nov 2011
any help
Nexus 4 MAKO
 
faddyie
Old
#7  
faddyie's Avatar
Senior Member - OP
Thanks Meter 45
Posts: 348
Join Date: Nov 2011
]any help
Nexus 4 MAKO
 
klvnhng
Old
#8  
klvnhng's Avatar
Senior Member
Thanks Meter 275
Posts: 755
Join Date: Dec 2012
Location: Toronto

 
DONATE TO ME
It might be a defective cable. I had the same thing happen to me (oem cable and charger), but changing the cable solved it for me. Pretty poor build quality if you ask me

Sent by carrier pigeon
The real problem is not whether machines think but whether people do. B. F. Skinner

OnePlus One (bacon) 64GB

 
jlk2501
Old
#9  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Aug 2011
Location: Sydney
i was using the original USB cable that came with the phone and experienced the same issues. after changing the USB cable it is fixed for me.

Sent from my Nexus 4 using xda app-developers app
 
ttheodorou
Old
#10  
Senior Member
Thanks Meter 21
Posts: 146
Join Date: Apr 2010
i can confirm that it is the cable. just go buy a new one but have in mind that you need a quality cable. the reason is that the usb 2 standard outputs about 1 amp, so most cable is designed with that in mind. the nexus 4 charger output is 1.2 amp so if the charger cannot output 1.2 amp it outputs lower amp thus the connection with the charger is recognized as usb. if you go and buy a quality cable then you will have no problems. i just use the cable of my old phone (optimus black ) and it works like a charm. another cable that i have make the usb thingy.

the lg cable of nexus 4 and all the new lg's is ****. it break down very easily. a friend of mine bought an lg g pad 8.3 and the cable died the 4 time that he used it!!!

P.S. when i say quality cable i don't mean a 30 euroes or dollars cable. i mean a cable by a known brand and not an ebay 1 euro cable. that didn't worked for me. if i knew a brand of cable that worked i would but i use an old lg cable

hope i helped

The Following User Says Thank You to ttheodorou For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes