Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Double Tap to Wake on the Nexus 6 Without Root

A few weeks ago, we featured an app which allowed the Nexus 6 to regain the double tap to wake … more

Make Your Own Heat Sink for the LG Optimus 4X HD

Its not a rare occurrence that performing a resource heavy task on your Android device (e.g. … more

Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Charging on AC but shows USB

OP faddyie

27th March 2014, 04:10 AM   |  #1  
faddyie's Avatar
OP Senior Member
Thanks Meter: 45
 
353 posts
Join Date:Joined: Nov 2011
Initially my phone started to charge slow since a week with the original charger and cable came with N4 in the box. I googled and got to check in the battery settings as if it shows AC or USB. Its showing USB and charging quite slow. I flashed yesterday factory image after deleting everything but still it shows as USB.
One more thing, when i connect the charger it shows AC and after a few seconds it says USB and sticks to it.
After connecting the charger it acts as the charger is powered on and off 3-4 times whereas i dont turn the power off/on.

Any help.
27th March 2014, 08:25 AM   |  #2  
faddyie's Avatar
OP Senior Member
Thanks Meter: 45
 
353 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by faddyie

Initially my phone started to charge slow since a week with the original charger and cable came with N4 in the box. I googled and got to check in the battery settings as if it shows AC or USB. Its showing USB and charging quite slow. I flashed yesterday factory image after deleting everything but still it shows as USB.
One more thing, when i connect the charger it shows AC and after a few seconds it says USB and sticks to it.
After connecting the charger it acts as the charger is powered on and off 3-4 times whereas i dont turn the power off/on.

Any help.

Anyone...?
The Following User Says Thank You to faddyie For This Useful Post: [ View ]
27th March 2014, 10:10 AM   |  #3  
TJ_Ahluwalia's Avatar
Senior Member
Flag Chennai
Thanks Meter: 93
 
220 posts
Join Date:Joined: Jan 2012
More
Happening to me too!! Please help someone.

Sent from my Nexus 4 using XDA Premium 4 mobile app
27th March 2014, 10:57 AM   |  #4  
senthilrameshjv's Avatar
Senior Member
Flag Chennai
Thanks Meter: 219
 
824 posts
Join Date:Joined: Nov 2011
More
Quote:
Originally Posted by TJ_Ahluwalia

Happening to me too!! Please help someone.

Sent from my Nexus 4 using XDA Premium 4 mobile app

Happens to me as well. I even got a new USB cable from Flipkart and tried with other chargers. Same thing happens. I googled enough for this and find no feasible solutions.
27th March 2014, 11:25 AM   |  #5  
faddyie's Avatar
OP Senior Member
Thanks Meter: 45
 
353 posts
Join Date:Joined: Nov 2011
It seems to be a hardware issue. but the weird things is it initially recognizes as AC but then after few seconds change to USB.
Further, after pinning the cable, phone reacts as the power is on-off-on-off 3-4 times.

Please help.
28th March 2014, 07:39 AM   |  #6  
faddyie's Avatar
OP Senior Member
Thanks Meter: 45
 
353 posts
Join Date:Joined: Nov 2011
any help
29th March 2014, 02:47 PM   |  #7  
faddyie's Avatar
OP Senior Member
Thanks Meter: 45
 
353 posts
Join Date:Joined: Nov 2011
]any help
30th March 2014, 02:22 PM   |  #8  
klvnhng's Avatar
Senior Member
Flag Toronto
Thanks Meter: 283
 
757 posts
Join Date:Joined: Dec 2012
Donate to Me
More
It might be a defective cable. I had the same thing happen to me (oem cable and charger), but changing the cable solved it for me. Pretty poor build quality if you ask me

Sent by carrier pigeon
31st March 2014, 01:54 PM   |  #9  
Junior Member
Flag Sydney
Thanks Meter: 0
 
4 posts
Join Date:Joined: Aug 2011
More
i was using the original USB cable that came with the phone and experienced the same issues. after changing the USB cable it is fixed for me.

Sent from my Nexus 4 using xda app-developers app
1st April 2014, 02:41 PM   |  #10  
Senior Member
Thanks Meter: 42
 
218 posts
Join Date:Joined: Apr 2010
More
i can confirm that it is the cable. just go buy a new one but have in mind that you need a quality cable. the reason is that the usb 2 standard outputs about 1 amp, so most cable is designed with that in mind. the nexus 4 charger output is 1.2 amp so if the charger cannot output 1.2 amp it outputs lower amp thus the connection with the charger is recognized as usb. if you go and buy a quality cable then you will have no problems. i just use the cable of my old phone (optimus black ) and it works like a charm. another cable that i have make the usb thingy.

the lg cable of nexus 4 and all the new lg's is ****. it break down very easily. a friend of mine bought an lg g pad 8.3 and the cable died the 4 time that he used it!!!

P.S. when i say quality cable i don't mean a 30 euroes or dollars cable. i mean a cable by a known brand and not an ebay 1 euro cable. that didn't worked for me. if i knew a brand of cable that worked i would but i use an old lg cable

hope i helped

The Following User Says Thank You to ttheodorou For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes