FORUMS

OnePlus 2 Teardown, Major Android Vulnerability – XDA TV

The OnePlus 2 has been officially released. That and much more news is … more

What Do You Think About Fingerprint Scanners?

More and more phones are featuring fingerprint scanners, and with many promising … more

What’s Next for Samsung and Its Flagships?

If we were to say that the Galaxy S6 was a leap of faith made by Samsung, we … more

The Ultimate Showcase of dBrand Skins

In the search for ways to protect, accessorize, and personalize; a user has many options. One … more

[Q] Cannot connect in MTP mode anymore. Tried a lot, still no solution...

144 posts
Thanks Meter: 14
 
By bragih, Senior Member on 6th January 2014, 07:39 PM
Post Reply Subscribe to Thread Email Thread
Hello everyone.
I don't know since when or how, since it has been always working for me on my win7 desktop, but when I tried to connect my phone to a new Latptop (with win8) during the holidays at home, it wouldn't detect it as an MTP device.

Well, it doesn't recognise it at all, unless I put it in debug mode, then it's under unknown devices as "Nexus 4" with a failed driver installation.

But I need to get MTP working to back some things up.

I'm running AOKP's Milestone for 4.3 and franco's kernel 193.
I checked if fastcharge was enabled: No
Switched it on and back off: Nothing
Reflashed the Kernel: Nothing
Reflashed AOKP (including the stock Kernel): Still not recognised

Of course several reboots included. Tried all slots and different cables. The cables tested all work for my N7 on Kitkat.

I had issues before with franco's kernel not really disabling fastcharge when I clicked it but I managed to fix that by rebooting or switching it back on and off again. Also this doesn't really give me any clues as I reflashed AOKP which comes with a different kernel that doesn't even support fast charge..

I'm kind of clueless now, I urgently need to back up things from my phone which I now did via Airdroid, but I also need to get MTP back working for bigger files.

Thank you very much for your help!
It would be nice if someone had a suggestion before I try going back to stock.
 
 
6th January 2014, 08:27 PM |#2  
opssemnik's Avatar
Senior Member
Flag Porto Alegre,Rio Grande Do Sul,Brasil
Thanks Meter: 940
 
More
turn off driver signature verification(ask google how to do)
install universal naked drivers.
there you go
The Following User Says Thank You to opssemnik For This Useful Post: [ View ]
6th January 2014, 08:52 PM |#3  
OP Senior Member
Thanks Meter: 14
 
More
Will it then only be recognised in debug mode? Or normal as well? Since it doesn't even appear in device manager right now when in regular USB mode

Gesendet von meinem Nexus 4 mit Tapatalk
7th January 2014, 09:33 AM |#4  
andredn8's Avatar
Member
Thanks Meter: 5
 
More
Try the way @opssemnik said, maybe your driver isnt work
7th January 2014, 09:46 AM |#5  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by andredn8

Try the way @opssemnik said, maybe your driver isnt work

I had this problem. Try deleting all android drivers and MTP drivers from your PC using USBDeview (google it). Also try connecting to a different PC to see if the phone can connect at all. Finally, you may need to unlock the lock screen before attaching. After that it connects no problems!
The Following User Says Thank You to jimbo34 For This Useful Post: [ View ]
7th January 2014, 12:50 PM |#6  
OP Senior Member
Thanks Meter: 14
 
More
Quote:
Originally Posted by jimbo34

I had this problem. Try deleting all android drivers and MTP drivers from your PC using USBDeview (google it). Also try connecting to a different PC to see if the phone can connect at all. Finally, you may need to unlock the lock screen before attaching. After that it connects no problems!

USBDeview did the trick. Thanks a lot.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes