Post Reply Subscribe to Thread Email Thread

[Q] About Debian on Android by chroot on KitKat AOSP

18th May 2014, 06:19 AM   |  #1  
OP Member
Thanks Meter: 34
 
55 posts
Join Date:Joined: May 2014
More
Hello everyone at XDA,

I have searched through the whole internet for some time and I couldnít find something that worked, So this is why Iím opening this thread.

I have today a Nexus 4 with stock 4.2.2 Kitkat, and I am searching for an app or something that could install a chroot with Debian in it.

I have too a Motorola Droid 3 with stock Android 2.3 Gingerbread that used an app called Linux Installer to build and install a chroot environment and everything worked as it should.

But Iíve tried to install it on the Nexus 4 and I couldnít, it gave me some strange errors, I believe that the app may be incompatible with newer firmwares.

Since then Iíve tried a lot of alternatives, and every one of them have failed at some point, Iíve tried:

Linux Deploy
Debian Kit
Lilí Debi
Linux Installer

Iím not a newbie, so I can at least assume that the apps havenít failed because I didnít know how to configure them, Iím just trying to figure out why them donít work.

I donít know if it helps, but the only modification that I have done to the device is that Iíve installed CWM and rooted it by flashing SuperSU. I tried installing busybox too but it didnít work (maybe something missing to do?)

So, have you guys been using a chroot on newer firmwares like 4.2.2? what app or method do you guys use?
25th January 2015, 09:49 PM   |  #2  
Junior Member
Thanks Meter: 2
 
4 posts
Join Date:Joined: Jun 2014
More
You could try to set selinux to permissive mode.
run following as root:
Code:
setenforce 0
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes