Post Reply

I get an error whenever I try to run Google Play over WIFI

OP ido_doron

10th January 2014, 02:51 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
12 posts
Join Date:Joined: Jul 2012
Since I bought my new Nexus 4, I haven't managed to run Google Play over WIFI.
It's very important to mention that my WIFI connection is completely fine, and I can surf the Internet without any problems.

Whenever I open Google Play as WIFI is turned on and connected, after a few seconds I receive the following error message: "Connection Timed Out" near a button which allows me to try again. This message is not shown if I turn off WIFI connection and connect my cellular internet network. If I don't use WIFI, I can run Google Play without any errors and download any application I want to download.

This is very very weird because my brother owns exactly the same device (Nexus 4) and he doesn't get any error messages when he's connected to the same WIFI connection. We both have kept the original Android stock rom, we both haven't rooted our phones and that's why I can't explain why only I get this message.

I have already googled about it and tried every suggestion I could find (For example: http://wccftech.com/fix-no-connectio...play-store-app). Nothing helped. I even tried to do a factory reset but it didn't change anything.

Does anyone know what causes this annoying problem? I don't know what to do anymore



* I don't want to root my phone and I don't want to replace the original ROM which came with my phone the day I bought it.
Last edited by ido_doron; 10th January 2014 at 02:57 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes