Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,453 Members 42,390 Now Online
XDA Developers Android and Mobile Development Forum

Facebook Messenger - Something went wrong error

Tip us?
 
mversion
Old
#1  
Member - OP
Thanks Meter 18
Posts: 58
Join Date: Jun 2008
Location: Melbourne
Default Facebook Messenger - Something went wrong error

Hey guys,

just got a Nexus 4 yesterday and it looks like I can't login to Facebook Messenger with my new phone. I am able to use Facebook messenger on my other Android devices with no issues.
Even the main Facebook app loads and runs just fine, but everytime I load up Messenger I get a "Something went wrong. Please try again." error.

I've uninstalled, reinstalled. Installed old versions, cleared app data and cache. Tried on stock and CM10.1 nightlies. Nothing. Even changed my password to something simpler, in case it didn't like the special characters. But nope.

Google would suggest a mix match of people having this issue and no resolution.

Anyone came across this issue and found a solution?
 
Maustin96
Old
#2  
Member
Thanks Meter 17
Posts: 60
Join Date: Jul 2012
Location: Perth

 
DONATE TO ME
Have you found a fix for this yet? Mine has been the same since I got it on the 9th of April. Works flawlessly on my N10 and worked on my S2 as well.
 
mversion
Old
#3  
Member - OP
Thanks Meter 18
Posts: 58
Join Date: Jun 2008
Location: Melbourne
Quote:
Originally Posted by Maustin96 View Post
Have you found a fix for this yet? Mine has been the same since I got it on the 9th of April. Works flawlessly on my N10 and worked on my S2 as well.
Nope. I've posted this issue on Reddit Nexus 4 sub too. I've emailed android-support@fb.com but I'm not hopeful. Hopefully there'll be a fix. But yeah, somehow it's an app + hardware combination. I get the same issue with my wife's login. Facebook app OK, messenger not OK. But don't have any issues with any other device.
 
Clemoly
Old
#4  
Junior Member
Thanks Meter 4
Posts: 15
Join Date: Jul 2011
I have the exact same issue on my n4. Fb app work, messenger and pages don't. Works on n7, tf300t, xperia arc etc. I can get messenger to work using old release though. Still not ideal, but try 1.8.002 release.

Very frustrating fb please fix asap

Sent from my Nexus 4 using xda app-developers app
The Following 2 Users Say Thank You to Clemoly For This Useful Post: [ Click to Expand ]
 
mversion
Old
#5  
Member - OP
Thanks Meter 18
Posts: 58
Join Date: Jun 2008
Location: Melbourne
Quote:
Originally Posted by Clemoly View Post
...Still not ideal, but try 1.8.002 release.
Thanks for that. I tried a few other 2.X releases which didn't work, but the 1.8.002 release you suggested does indeed work for me too. I got it from: http://www.androiddrawer.com/1954/do...-8-002-app-apk for anyone else having the same issue.

I emailed Facebook support back when I started this thread, and still heard nothing back. I expect a copy/paste response when I do though.
The Following User Says Thank You to mversion For This Useful Post: [ Click to Expand ]
 
Maustin96
Old
#6  
Member
Thanks Meter 17
Posts: 60
Join Date: Jul 2012
Location: Perth

 
DONATE TO ME
Thanks mversion and Clemoly!
 
mversion
Old
#7  
Member - OP
Thanks Meter 18
Posts: 58
Join Date: Jun 2008
Location: Melbourne
Just an update that the newly released version (2.6.1) doesn't work either. Instead of giving a "something went wrong" error, it just continuously takes me back to the CONTINUE AS "FB NAME" screen. My last hope is that Jelly Bean 4.3 fixes it. But probably not.
 
Maustin96
Old
#8  
Member
Thanks Meter 17
Posts: 60
Join Date: Jul 2012
Location: Perth

 
DONATE TO ME
We all live in Australia.... Weird...
 
javier_83
Old
#9  
Member
Thanks Meter 1
Posts: 33
Join Date: Nov 2012
Quote:
Originally Posted by mversion View Post
Just an update that the newly released version (2.6.1) doesn't work either. Instead of giving a "something went wrong" error, it just continuously takes me back to the CONTINUE AS "FB NAME" screen. My last hope is that Jelly Bean 4.3 fixes it. But probably not.
This happen to me too, i don't receive the messages notifications and i have also the same message (something went wrong).

i am using the last version
 
mversion
Old
#10  
Member - OP
Thanks Meter 18
Posts: 58
Join Date: Jun 2008
Location: Melbourne
I had a chance to install Facebook Messenger on a colleague's Nexus 4 (he didn't have it previously installed, nor does he have a Facebook account) and lo and behold, I was able to sign in with my own credentials.

So I thought I'd format my Nexus, start fresh and install Facebook Messenger before I installed anything else, including the Facebook main app. Well, I STILL GET THE DAMN SOMETHING WENT WRONG ERROR. The peculiar thing is that it didn't even get to the stage where it would send me a verification SMS (Facebook's 2-step verification feature), it just said something went wrong and that's it.

Somehow, just somehow, this feels like a hardware related thing. I don't know, but I think I am going to offer my colleague some money to swap our Nexus!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes