5,595,645 Members 44,190 Now Online
XDA Developers Android and Mobile Development Forum

Mobile data used even when disabled in settings

Tip us?
 
mara-
Old
#1  
Member - OP
Thanks Meter 7
Posts: 67
Join Date: Oct 2012
Default Mobile data used even when disabled in settings

Hi,

I have a Nexus 4 with latest KitKat and franco's kernel. I didn't update via OTA. I keep my mobile data disabled, but it seems that my phone randomly use mobile data. Data graph does not register it, but I can here the noise in my computer speakers, and my stupid mobile provider always sends me SMS when I start using mobile internet, so I know it's using it. So, any idea why this happens and how to stop it? Thanks.
 
andrew.golby
Old
#2  
Junior Member
Thanks Meter 4
Posts: 15
Join Date: Jul 2013
Quote:
Originally Posted by mara- View Post
Hi,

I have a Nexus 4 with latest KitKat and franco's kernel. I didn't update via OTA. I keep my mobile data disabled, but it seems that my phone randomly use mobile data. Data graph does not register it, but I can here the noise in my computer speakers, and my stupid mobile provider always sends me SMS when I start using mobile internet, so I know it's using it. So, any idea why this happens and how to stop it? Thanks.
Is it happening when your phone is slipping back into 2G - even if not being used the phone send paging signals to the network every so often - you'll hear it especially before a call or SMS comes in as the network sets up the call. Whilst technically it is transmitting small amounts of paging data it isn't charged to you.
 
mara-
Old
#3  
Member - OP
Thanks Meter 7
Posts: 67
Join Date: Oct 2012
Quote:
Originally Posted by andrew.golby View Post
Is it happening when your phone is slipping back into 2G - even if not being used the phone send paging signals to the network every so often - you'll hear it especially before a call or SMS comes in as the network sets up the call. Whilst technically it is transmitting small amounts of paging data it isn't charged to you.
Well, I keep it on 2g only, so that's not what is happening, and I mentioned that I get sms from provider when my mobile data is used. I just upgraded to 4.4.1, so I'll see if it still happens.

In meantime, if anyone has any idea why this might happen, please post.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes