Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Nexus 4 signal and battery problems

OP dinesh690

7th April 2014, 07:41 PM   |  #1  
dinesh690's Avatar
OP Retired Forum Moderator
Flag UK
Thanks Meter: 1,570
 
818 posts
Join Date:Joined: Dec 2011
Donate to Me
More
Hello there,

So, I had my phones screen repaired a few weeks ago. For the last two 2 weeks or so, after the phone loses about 30% charge it will start losing signal and then regaining it and this will occur for about 5 mins and then the phone will shut down weather its at 15% or 70%.

After this, everytime I reboot the phone it will turn off within 20 seconds even though it will still have plenty of charge on it. However, It is a dirty shut down. It won't say phone is shutting down, it will just turn off instantly

The only way to solve it is to charge the phone. It will say it still has charge once I put it on charge and that the battery is not fully drained and once it reaches a high enough percentage (e.g 80%). I will be able to use the phone till it drops round about another 30% and the cycle will begin again.

I have tried switching to multiple ROMs and wiping everything of course so it must be a hardware issue. Do you think it is a dodgy battery? Or what could be causing this issue? Any help would be greatly appreciated

Thank you
Last edited by dinesh690; 7th April 2014 at 07:43 PM.
8th April 2014, 06:07 AM   |  #2  
raj_luvs_frnds's Avatar
Member
Flag RAJASTHAN
Thanks Meter: 2
 
79 posts
Join Date:Joined: Aug 2007
More
Quote:
Originally Posted by dinesh690

Hello there,

So, I had my phones screen repaired a few weeks ago. For the last two 2 weeks or so, after the phone loses about 30% charge it will start losing signal and then regaining it and this will occur for about 5 mins and then the phone will shut down weather its at 15% or 70%.

After this, everytime I reboot the phone it will turn off within 20 seconds even though it will still have plenty of charge on it. However, It is a dirty shut down. It won't say phone is shutting down, it will just turn off instantly

The only way to solve it is to charge the phone. It will say it still has charge once I put it on charge and that the battery is not fully drained and once it reaches a high enough percentage (e.g 80%). I will be able to use the phone till it drops round about another 30% and the cycle will begin again.

I have tried switching to multiple ROMs and wiping everything of course so it must be a hardware issue. Do you think it is a dodgy battery? Or what could be causing this issue? Any help would be greatly appreciated

Thank you

hi frnd,

i think its a battery issue. get it changed and everything will be fine...

Thanks & Regards
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes