Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,094 Members 50,189 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Nex4 shows [USB] charging on all chargers

Tip us?
 
SneakyGuyDavid
Old
(Last edited by SneakyGuyDavid; 7th February 2014 at 08:39 PM.)
#1  
SneakyGuyDavid's Avatar
Senior Member - OP
Thanks Meter 47
Posts: 248
Join Date: Jan 2013
Location: Providence, RI
Question [Q] Nex4 shows [USB] charging on all chargers

PROBLEM SOLVED



for some reason my new nexus 4 charges on USB mode no matter what charger i use, now here is the weird part...

i have 2 motherboards, one from a previous nexus 4 and when i drop the motherboard into the phone without changing usb port or anything, it will show it is charging on AC for the proper chargers (Wall chargers).

can the motherboard really control the charging rate? i thought it would be a usb port problem, but nope, works fine on my older motherboard which has Carbon 4.3.1 , my newer one is running Carbon 4.4 , ill try to make a nandroid and flash another rom to check if its just rom (which wouldnt make much sense but whatevs).

any input, tips, or advice would be awesome

btw, im using the default battery option in the settings app to check if it is USB or AC , so if anyone knows any apps to confirm rate that would be cool too

UPDATE: tried CM 11, yep it was my rom (carbon 4.4) and or kernel (Faux U31), i wonder why though


Devices:
~Nexus 4 16GB [Mako] {Mahdi-Rom} Primary device ; Got a new one in white !
~HTC First [Myst] {Stock JB rooted}
~Galaxy Tab 2 7.0 8GB [GT-P3113] {AOKP KK} Family tab
~HTC Evo [Supersonic] {AOKP JB} Wifi Only
 
Zehlek
Old
#2  
Zehlek's Avatar
Senior Member
Thanks Meter 1,135
Posts: 3,870
Join Date: Jul 2010
Location: Niagara Falls
Quote:
Originally Posted by SneakyGuyDavid View Post
for some reason my new nexus 4 charges on USB mode no matter what charger i use, now here is the weird part...

i have 2 motherboards, one from a previous nexus 4 and when i drop the motherboard into the phone without changing usb port or anything, it will show it is charging on AC for the proper chargers (Wall chargers).

can the motherboard really control the charging rate? i thought it would be a usb port problem, but nope, works fine on my older motherboard which has Carbon 4.3.1 , my newer one is running Carbon 4.4 , ill try to make a nandroid and flash another rom to check if its just rom (which wouldnt make much sense but whatevs).

any input, tips, or advice would be awesome

btw, im using the default battery option in the settings app to check if it is USB or AC , so if anyone knows any apps to confirm rate that would be cool too
+1 I get that all the time and I use the default nexus 4 charger they came with it. I have to enable force fast charge a lot of times


Sent from my Nexus 4 using Tapatalk
 
SneakyGuyDavid
Old
(Last edited by SneakyGuyDavid; 7th February 2014 at 04:49 AM.)
#3  
SneakyGuyDavid's Avatar
Senior Member - OP
Thanks Meter 47
Posts: 248
Join Date: Jan 2013
Location: Providence, RI
Quote:
Originally Posted by Zehlek View Post
+1 I get that all the time and I use the default nexus 4 charger they came with it. I have to enable force fast charge a lot of times


Sent from my Nexus 4 using Tapatalk
yeah i've tried enabling fastcharge on faux but it doesnt seem to do anything really, something's probably up with carbon 4.4 its still new and the carbon team's server is down right now so there wont be new builds till atleast this weekend, i guess i can suck it up intill i figure out my problem its only charging which normally i only do while i sleep, if i switch to any other rom it has to be feature filled like carbon, carbon basically has a little bit of everything (before 4.4 update which broke compatibilty) thats why i like it.

EDIT: Redownloaded Carbon 4.4 (latest nightlty is 2/5/14 as of now) and i Didn't flash faux and AC works perfect... im slowly but surely solving my own problem, im gonna redownload faux and see if that is what is causing the USB speed chatting

Update: found the solution to my problem, it was faux kernel, but in the sense that if you leave fast charging on FORCE AC it won't do ****, it will actually then make everything charge at USB speed, so put it on disabled like I needed to do.


Devices:
~Nexus 4 16GB [Mako] {Mahdi-Rom} Primary device ; Got a new one in white !
~HTC First [Myst] {Stock JB rooted}
~Galaxy Tab 2 7.0 8GB [GT-P3113] {AOKP KK} Family tab
~HTC Evo [Supersonic] {AOKP JB} Wifi Only
The Following User Says Thank You to SneakyGuyDavid For This Useful Post: [ Click to Expand ]
 
Masrepus
Old
#4  
Masrepus's Avatar
Senior Member
Thanks Meter 72
Posts: 650
Join Date: Feb 2013
Mh but i had the same problem, but on stock!
It turned out that my ac to usb adapter was like too weak for the phone or whatever, amyways if i use the adapter of my panasonic digicam, it works just fine

---------------------------------
Phone : My new Nexus 4!
OS:
Pure KitKat 4.4.2 stock, no root, no mods (but only for the first time ;D)
---------------------------------

Gesendet von Tapatalk
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes