Post Reply

[Q] Nexus 4 no longer recognised as a device on Mac OSX

OP Jacoaks

17th April 2014, 06:05 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2013
Hi Folks,

I've been unable to sync photos to iPhoto on my Mac (10.9.2) for a few months now. Decided to upgrade to latest 4.4.2 (update from google) but it's still not recognized as a device. As far as I remember if I had it in MTP mode, when I plugged the phone in iPhoto used to open with options to sync photos.

I previously rooted the phone with CWM and SuperSU, the device does appear in the list when I run:

$ ./adb-mac devices
List of devices attached
01637f56g7814390 device

When USB debugging is turned on, a message "USB debugging connected" appears on screen, but iphoto doesn't see the device, and nothing in Disk Utility either. Android File transfer says: "No Android device found".

Any help to get photo sync / file transfer operational again much appreciated.

Thanks
17th April 2014, 07:27 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2013
The 4.4.2 update seems to be fine, haven't noticed anything weird, certainly no 'bricking', it's the photo syncing / device detection that still doesn't work (it wasn't syncing before the upgrade). I'm looking for some troubleshooting ideas, like log files to look at, or some options to try. I've tried several usb cables, same result.
[Edit: the poster I was replying to deleted their comment about their phone getting bricked, oh well]
Last edited by Jacoaks; 17th April 2014 at 11:03 PM.
18th April 2014, 08:34 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2013
Found the option, it's buried in
Settings>Storage>...Menu>USB computer connection>Camera (PTP)
very intuitive thank u google

Hopefully this will be helpful to someone else out there
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes