Post Reply

[Q] Touch screen goes crazy when charging?

OP btse

23rd December 2012, 08:09 AM   |  #1  
OP Member
Thanks Meter: 16
 
71 posts
Join Date:Joined: May 2011
More
Whenever I plug in my charger, my touch screen starts going bonkers, but unplugged it performs perfectly fine. I have turned on pointer locations to see what is going on. The touch screen fails to register touches and also fails to keep track of my finger. For instance, if I quickly swipe my finger up and down repeatedly, it will only track my finger for a very short amount of time, and sometimes fails to follow my finger at all. Unplugged, it continuously tracks my finger. Has anyone had a similar problem?

I have tested multiple chargers using my computer and a wall outlet. The problem always persists.
23rd December 2012, 08:12 AM   |  #2  
jacklebott's Avatar
Senior Member
Flag Land of the Idiots
Thanks Meter: 490
 
1,642 posts
Join Date:Joined: Oct 2010
More
That's a problem on just about any smartphone. It's something to do with the voltage supplied
23rd December 2012, 08:13 AM   |  #3  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Dec 2012
I have the same problem, except that the screen registers more touches and my device is a Micromax A75.

Sent from my A75 using Tapatalk 2
23rd December 2012, 04:02 PM   |  #4  
Senior Member
Flag Eastbourne
Thanks Meter: 10
 
110 posts
Join Date:Joined: Sep 2008
More
I had the same problem with my one x. It was because I was using a different charger. Ensure you are using the stock charger and if the problem persists, try a different micro usb lead!

Sent from my Nexus 4 using xda app-developers app
23rd December 2012, 08:06 PM   |  #5  
OP Member
Thanks Meter: 16
 
71 posts
Join Date:Joined: May 2011
More
I have tried three different chargers, same thing happens with each of them.

Sent from my Nexus 4 using xda app-developers app
6th June 2014, 04:57 PM   |  #6  
cimdrap's Avatar
Senior Member
Thanks Meter: 77
 
395 posts
Join Date:Joined: Dec 2010
same here with aftermarket charger, i lost the original one. Is there a solution?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes