5,815,061 Members 37,280 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Nexus 4 - Stuck in Bootloader, unsuccessful ADB access -

Tip us?
 
SidCurry
Old
(Last edited by SidCurry; 20th June 2014 at 05:15 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Jun 2014
Unhappy [Q] Nexus 4 - Stuck in Bootloader, unsuccessful ADB access -

Hi guys,
I had posted a brief thread a couple weeks ago stating that my Nexus 4 restarted by itself, and got stuck in the bootloader animation loop. I couldn't remember whether I had enabled USB debugging in my phone prior to it killing itself (not rooted, completely stock, did the OTA 4.4.3 update just a few days before my phone died, and phone's been out of warranty for quite a while now ).
So I installed the SDK developer tooklit, and followed instructions to set up ADB.
However, everytime I boot my nexus 4 into recovery mode/"safe" mode, I get the following screen ("Screenshot 1" below).
From there, when I boot into recovery mode, I get the following screen ("Screenshot 2").
Every time I connected my phone to my laptop (keep in mind that I cannot start it .. I always plug it in when I'm in "Screenshot 1" mode) and try to used "adb devices", I get the following cmd screen ("CMD ADB Devices" picture below). I've repeated this process and tried plugging the nexus in during various points in different "safe mode" options. Same result: nothing is detected.

So I got frustrated at trying to backup any data from my phone, and just chose the "wipe data/factory reset" option from the nexus recovery mode, and I got this screen ("Screenshot 3"). I've tried this several times, and I keep getting this screen.

So my nexus committed suicide, and I'm totally not sure what to do. I've been trying to learn how to use ADB etc for the past couple of days by scouring through the xda nexus 4 forums, but I'm still very much a n00b. Do you guys have any advice as to what I can do to get my nexus 4 back to a usable state again?

Things I've already tried (in order):
http://forum.xda-developers.com/nexu...image-t2010312
http://forum.xda-developers.com/gala...-root-t1420351

I also tried to ADB sideload a stock Nexus 4.4.3 factory image, but it is useless since my device won't even show up in CMD when i enter ADB devices.
However, the problem is that my nexus is never detected in CMD no matter what combination of things I tried, so I can't even do half of the things both of those thread instructions state.

I would greatly appreciate ANY ways to factory reset or flash working firmware on my phone!

Edit: I reinstalled Android SDK, and connected my nexus to my laptop after entering fastboot ("safe" mode; volume down + power from phone off state), and I was able to get a slightly better looking CMD window when running ADB Devices command (See "CMD ADB Devices 2" picture). However, same problem as before, where my phone isn't even registering via ADB.
So again, your input would be tremendously appreciated.
Attached Thumbnails
Click image for larger version

Name:	Screenshot 1.jpg
Views:	44
Size:	247.7 KB
ID:	2807629   Click image for larger version

Name:	Screenshot 2.jpg
Views:	53
Size:	256.1 KB
ID:	2807630   Click image for larger version

Name:	Screenshot 3.jpg
Views:	48
Size:	265.2 KB
ID:	2807631   Click image for larger version

Name:	CMD ADB Devices.JPG
Views:	47
Size:	31.8 KB
ID:	2807632   Click image for larger version

Name:	CMD ADB Devices 2.JPG
Views:	39
Size:	35.9 KB
ID:	2807773  

 
mihahn
Old
#2  
mihahn's Avatar
Recognized Contributor
Thanks Meter 2,176
Posts: 3,221
Join Date: May 2012
If you boot in the bootloader (Volume- and Power) it's normal that you can't use adb. You have to use fastboot in the bootloader.

What is the output of fastboot devices?
Code:
fastboot devices
Have you already tried to flash the factory image or did this fail, too? You have to download the factory image from google, extract it and connect the phone in the bootloader/fastboot mode. Run the flash-all.bat then and it will reflash the stock rom. This will wipe your data, but I guess this shouldn't be a problem for you anymore because you already tried to do a factory reset!

If this worked, boot your phone and if it works fine, I would recommend to relock the bootloader (because it gets unlocked automatically if you flash the factory image and if you don't want to root/modify your phone in any way, your bootloader is usually locked):
Code:
fastboot oem lock
Try it and if there are any other problems or if it doesn't work, just ask again


Devices/Links/Information:
 

Device:Google Nexus 4 8gb
ROM:Stock Android 4.4.2 [KOT49H]

Device:Google Nexus 7 32gb
ROM:Stock Android 4.4.2 [KRT16O]

Device:Xperia Mini Pro SK17i
ROM: Super Jelly Bean 8.0
Kernel:nAa 2.6 [CWM]

Device:Raspberry Pi Model B
OS: Arch Linux

For a Rooting Guide for xperia 2011 devices, click me! | To unlock the Bootloader, click me! | How to install a custom kernel/rom? Click me | Super Jelly Bean 8.0 for xperia mdpi
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes