Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,180 Members 40,170 Now Online
XDA Developers Android and Mobile Development Forum

Nexus 4 USB not recognized

Tip us?
 
superbanana321
Old
(Last edited by superbanana321; 23rd May 2014 at 10:45 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: May 2014
Default Nexus 4 USB not recognized

Hello, long story short...
Stuck on google screen, no ROM, just TWRP. ADB Fastboot don't work, phone will charge, but windows 8.1 won't recognize it, it just says USB Descriptor Failed and Not Recognized. Drivers for it don't work either.

Bad Motherboard?

EDIT:

I already tried swapping the USB PCB from another fully working Nexus 4 and it did not work anyway, while the one from this damaged one did work correctly on the other already working N4 O_o
 
DrFredPhD
Old
#2  
Senior Member
Thanks Meter 39
Posts: 294
Join Date: Oct 2010
Take it you've tried another cable and usb port on comp? Also a good chance that this is charging block on the phone rather than motherboard. Worth a try.
 
jd1639
Old
#3  
jd1639's Avatar
Recognized Contributor
Thanks Meter 3,208
Posts: 9,506
Join Date: Sep 2012
Location: Minnetonka, MN
This may help http://forum.xda-developers.com/show...php?p=42022027

Sent from my Nexus 5 using XDA Free mobile app
 
superbanana321
Old
(Last edited by superbanana321; 23rd May 2014 at 10:43 PM.)
#4  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: May 2014
Quote:
Originally Posted by jd1639 View Post
This may help http://forum.xda-developers.com/show...php?p=42022027

Sent from my Nexus 5 using XDA Free mobile app
I already tried that, but without the correct Device ID the drivers don't do nothing. Tried forcing them on the Unrecognized USB Device, but it failed to communicate with the phone entirely. I tried swapping another USB PCB from my wife's N4 and same problem... I think I killed this thing... man... Should I try a Laptop with Ubuntu?

EDIT:

I read in another post that it might be the internal USB connector pins (the little orange cable that plugs into the mainboard), I will check this and see if I can straighten them out. Will post back results for everyone wanting to know if this was the problem
 
superbanana321
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: May 2014
I think I found the problem, one of the transistors is kind of blown...

Click image for larger version

Name:	part1.jpg
Views:	81
Size:	24.7 KB
ID:	2759877

Does anyone know where I can get a replacement resistor/transistor? Doesn't look that difficult to solder.
 
superbanana321
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: May 2014
Looks like something is bad internally, logic board replacement is inevitable. The component is called a Transient Voltage Suppressor (TVS), it's meant to protect other components, but even after shorting it still throws a not recognized message. Sorry for everyone reading this thread, you will need a replacement motherboard (logic board).
 
magote
Old
#7  
Senior Member
Thanks Meter 59
Posts: 140
Join Date: Nov 2009
Getting the same problem, happened because of a short circuit on the car charger. Really not possible to change only the transistor? Can live without the working usb, but the horrible battery life is killing me.

Sent from my Nexus 4 using Tapatalk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes