FORUMS

XDA Picks: Best Apps of the Week (May 15 – 30)

Apps are at the front and center of any smartphone experience, and with over a … more

Google No Longer Sending Calendar SMS Notifications

In a not entirely surprising move, Google announced that it’s putting an … more

Enable Multi-Window Mode on M Developer Preview

What was not mentioned in yeterday’s keynote was Android M’s multi-window … more

I/O Summary: Google Cardboard Virtual Reality

One year ago, Google introduced cardboard. Amazingly enough, that was all it took to fire … more

Nexus 4 USB not recognized

Thanks Meter: 0
 
By superbanana321, Junior Member on 23rd May 2014, 07:50 PM
Post Reply Subscribe to Thread Email Thread
Hello, long story short...
Stuck on google screen, no ROM, just TWRP. ADB Fastboot don't work, phone will charge, but windows 8.1 won't recognize it, it just says USB Descriptor Failed and Not Recognized. Drivers for it don't work either.

Bad Motherboard?

EDIT:

I already tried swapping the USB PCB from another fully working Nexus 4 and it did not work anyway, while the one from this damaged one did work correctly on the other already working N4 O_o
Last edited by superbanana321; 23rd May 2014 at 10:45 PM.
 
 
23rd May 2014, 07:54 PM |#2  
Senior Member
Thanks Meter: 40
 
More
Take it you've tried another cable and usb port on comp? Also a good chance that this is charging block on the phone rather than motherboard. Worth a try.
23rd May 2014, 08:32 PM |#3  
jd1639's Avatar
XDA: ASSIST
Recognized Contributor
Minnetonka, MN
Thanks Meter: 4,704
 
Donate to Me
More
This may help http://forum.xda-developers.com/show...php?p=42022027

Sent from my Nexus 5 using XDA Free mobile app
23rd May 2014, 10:33 PM |#4  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by jd1639

This may help http://forum.xda-developers.com/show...php?p=42022027

Sent from my Nexus 5 using XDA Free mobile app

I already tried that, but without the correct Device ID the drivers don't do nothing. Tried forcing them on the Unrecognized USB Device, but it failed to communicate with the phone entirely. I tried swapping another USB PCB from my wife's N4 and same problem... I think I killed this thing... man... Should I try a Laptop with Ubuntu?

EDIT:

I read in another post that it might be the internal USB connector pins (the little orange cable that plugs into the mainboard), I will check this and see if I can straighten them out. Will post back results for everyone wanting to know if this was the problem
Last edited by superbanana321; 23rd May 2014 at 10:43 PM.
24th May 2014, 01:28 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
I think I found the problem, one of the transistors is kind of blown...

Click image for larger version

Name:	part1.jpg
Views:	121
Size:	24.7 KB
ID:	2759877

Does anyone know where I can get a replacement resistor/transistor? Doesn't look that difficult to solder.
25th May 2014, 06:50 AM |#6  
OP Junior Member
Thanks Meter: 0
 
More
Looks like something is bad internally, logic board replacement is inevitable. The component is called a Transient Voltage Suppressor (TVS), it's meant to protect other components, but even after shorting it still throws a not recognized message. Sorry for everyone reading this thread, you will need a replacement motherboard (logic board).
28th May 2014, 12:15 PM |#7  
Senior Member
Thanks Meter: 59
 
More
Getting the same problem, happened because of a short circuit on the car charger. Really not possible to change only the transistor? Can live without the working usb, but the horrible battery life is killing me.

Sent from my Nexus 4 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes