Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Nexus 4 WiFi Problem

OP Timzter

4th December 2012, 10:27 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Sep 2009
I rooted and flashed my phone last night and everything was fine other than 1 thing. The Wi-Fi wouldn't connect on my home router. I tried several different roms and was left with the same problem where it was stuck on either obtaining ip address or authenticating. I then came into work this morning and the phone connected to my Wi-Fi network straight away.
Does anyone know how I can get around this problem, don't want to be using up all my data at home!

Thanks in advance
4th December 2012, 11:30 PM   |  #2  
Member
Thanks Meter: 7
 
44 posts
Join Date:Joined: Dec 2011
More
Dont get me wrong but did you try to restart the Router?

Sent from my HTC using XDA Windows Phone 7 App
4th December 2012, 11:43 PM   |  #3  
Senior Member
Flag Davis, CA
Thanks Meter: 65
 
196 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by Timzter

I rooted and flashed my phone last night and everything was fine other than 1 thing. The Wi-Fi wouldn't connect on my home router. I tried several different roms and was left with the same problem where it was stuck on either obtaining ip address or authenticating. I then came into work this morning and the phone connected to my Wi-Fi network straight away.
Does anyone know how I can get around this problem, don't want to be using up all my data at home!

Thanks in advance

I second the other suggestion. Those symptoms sound like your router needs a restart if it hangs at getting IP/authenticating.
5th December 2012, 01:51 AM   |  #4  
Heartbreak's Avatar
Senior Member
Flag Muncie, Indiana
Thanks Meter: 13
 
169 posts
Join Date:Joined: Apr 2010
More
I'm having the same problem on the network at my university.
6th December 2012, 08:16 PM   |  #5  
Member
Thanks Meter: 3
 
75 posts
Join Date:Joined: Mar 2006
Thumbs down
I'm having problems with my wifi as well. We have a network here at my office secured with WEP. My galaxy nexus connects to it just fine but my Nexus 4 refuses. It sees the network, show strong signal but it doesn't seem to connect. I did manage to get it to connect once and I downloaded some updates but then the connection dropped and will not reconnect. I've tried various advanced settings (forcing the network to 2.4GHz, changing the power options, etc... No joy. This is particularly frustrating for me as my micro sim has not yet arrived so WiFi is all I have Hopefully it will work at home. At least there I have access to the router so I can make changes if needed. So far not a fan though.
6th December 2012, 11:55 PM   |  #6  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Dec 2012
I've got WiFi problems here, too. Roaming between different WiFi networks (home and university) often results in an non functional WiFi connection. Experienced this problem with stock Android 4.2 on Nexus 4 and Galaxy Nexus and latest CM 10.1 nightly on Nexus 4. Even reboot doesn't help every time.

As workaround: If WiFi connection is broken, turn on "flight mode", wait a few seconds and turn it off again. Works for me, maybe it works for your problems too.
7th December 2012, 02:51 AM   |  #7  
dyslexicpenguin's Avatar
Member
Thanks Meter: 28
 
90 posts
Join Date:Joined: Nov 2012
I literally just received my nexus 4, and I haven't done anything with the SIM card yet, I just wanted to get things going on WiFi to start. It sees the network I want, let's me type in the password, and lets me click connect. After that it does literally nothing. No thinking, no obtaining IP address, nothing. Any ideas?
7th December 2012, 05:18 AM   |  #8  
Member
Salt Lake
Thanks Meter: 66
 
75 posts
Join Date:Joined: Jan 2010
More
Quote:
Originally Posted by dyslexicpenguin

I literally just received my nexus 4, and I haven't done anything with the SIM card yet, I just wanted to get things going on WiFi to start. It sees the network I want, let's me type in the password, and lets me click connect. After that it does literally nothing. No thinking, no obtaining IP address, nothing. Any ideas?

I have exactly the same problem. Got the phone today and have tried several different access points - no luck. Restart the phone, no change.

Also, system updates screen said I could only download the update to 4.2 from a wifi connection till the 7th, so i set the date to the 7th and did the update successfully over the cell connection. Still no WiFi. Factory reset - no change.

---------- Post added at 09:18 PM ---------- Previous post was at 09:17 PM ----------

Oh, also tried the flight mode "trick" with no success.
7th December 2012, 05:49 AM   |  #9  
Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by Heartbreak

I'm having the same problem on the network at my university.

Your uni wifi probably is LEAP wifi or PEAP wifi, which is proven broken in Android 4.2
7th December 2012, 07:59 AM   |  #10  
jim.k.yee's Avatar
Member
Flag New York
Thanks Meter: 12
 
62 posts
Join Date:Joined: Jan 2012
Donate to Me
More
Quote:
Originally Posted by ecsk

Your uni wifi probably is LEAP wifi or PEAP wifi, which is proven broken in Android 4.2

It's also broken on my campus. Do you have any suggestions to bypass this?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes