Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,156 Members 46,300 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Nexus won't detect replacement battery

Tip us?
 
Muthor6
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2011
Default [Q] Nexus won't detect replacement battery

Hi guys.
I bought a Nexus 4 from Ebay but ever since it arrived I've been having problems with the original battery (the battery would drop from 80% charge to 0, the phone would refuse to start up until i connected it to the charger, and cell signal would drop every now and then).

I just bought an original replacement battery, but after I installed it, the phone would not start, so i put it on charger and the white lightning would pop up and show that the battery is being charged.
The problem is - even after 10 hours at this state, the battery did not charge at all. The phone won't do anything without the charger connected at all, and when i hold the power button with the charger connected the phone just blinks red and restarts to the charging screen every time.
The phone is just acting the same as it is acting without any battery inserted at all.

So to clarify - new battery is not charging, I can get to bootloader mode and charging screen, and when i try to start up the device I get one quick blink from the red notif. light and quick restart back to the charging screen.

I'm having the new battery replaced on monday just in case I bought a faulty replacement battery, but do you have any tips in the meantime on how could I fix the issue?
 
scream4cheese
Old
#2  
scream4cheese's Avatar
Senior Member
Thanks Meter 853
Posts: 2,986
Join Date: Jun 2011
Location: New York, NY
Quote:
Originally Posted by Muthor6 View Post
Hi guys.
I bought a Nexus 4 from Ebay but ever since it arrived I've been having problems with the original battery (the battery would drop from 80% charge to 0, the phone would refuse to start up until i connected it to the charger, and cell signal would drop every now and then).

I just bought an original replacement battery, but after I installed it, the phone would not start, so i put it on charger and the white lightning would pop up and show that the battery is being charged.
The problem is - even after 10 hours at this state, the battery did not charge at all. The phone won't do anything without the charger connected at all, and when i hold the power button with the charger connected the phone just blinks red and restarts to the charging screen every time.
The phone is just acting the same as it is acting without any battery inserted at all.

So to clarify - new battery is not charging, I can get to bootloader mode and charging screen, and when i try to start up the device I get one quick blink from the red notif. light and quick restart back to the charging screen.

I'm having the new battery replaced on monday just in case I bought a faulty replacement battery, but do you have any tips in the meantime on how could I fix the issue?
If this continues to happen after replacing the battery again, the charging port must be fried.
My Devices

LG Nexus 4 8GB
Asus Nexus 7 (2013) 16GB
Chromecast



 
Muthor6
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2011
Quote:
Originally Posted by scream4cheese View Post
If this continues to happen after replacing the battery again, the charging port must be fried.
See but the thing is, the phone charges the old battery just fine. I'm charging it right now as we speak.
 
DrFredPhD
Old
#4  
Senior Member
Thanks Meter 28
Posts: 254
Join Date: Oct 2010
Battery is probably copy/faulty, get a replacement.
 
THEBANDIT420
Old
#5  
THEBANDIT420's Avatar
Senior Member
Thanks Meter 98
Posts: 319
Join Date: Aug 2013
Might not actually be a battery problem sounds more like the red light of death, which may have been caused by the battery changing but doesn't mean the battery is actually the problem. Plenty of threads around here on how to fix rlod

Sent from my Nexus 4 using XDA Premium 4 mobile app
 
Muthor6
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2011
Quote:
Originally Posted by THEBANDIT420 View Post
Might not actually be a battery problem sounds more like the red light of death, which may have been caused by the battery changing but doesn't mean the battery is actually the problem. Plenty of threads around here on how to fix rlod
Well I thought so too, but I have tried literally everything except charging the battery with separate cables outside the phone and nothing helped. I actually think this can't be it, because I couldn't find a single thread about having RLOD after replacing battery on the internet. Anyway, I'll exchange the new battery for another new battery on monday and see if that helps or not.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...