5,815,214 Members 39,049 Now Online
XDA Developers Android and Mobile Development Forum

Need (expert?) opinion

Tip us?
 
seminarian
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Jun 2012
Question Need (expert?) opinion

Hi guys,

I'm posting here after another afternoon messing with my phone.
Here's how the story goes.. My Nexus 4 fell on the ground and broke the glass, the touch screen wasn't working anymore. So i've decided to order a new screen online and replace it. This is the screen i've ordered. http://www.spareslg.com/lcd-e-touch-...q86270901.html

In retrospect i used a bad guide to change it and kinda freestyled replacing the parts. I forgot to move the power and volume button. I've also wrecked my battery in the process of replacing the screen (twice). So I've ordered a new one. (yeah I'd better followed the guide on the page of the item seller, but what's done is done.. right)

Anyway, after many hours struggling with my phone I'm at this point:
The phone boots and i stuck on google logo with a lock symbol at the bottom. If I press volume down and power button I get in the bootloader.
If in the bootloader I select recovery mode the phone boots into ClockworkMod Recovery v6.0..4.3. I get the menu of CWM but and the bottom of the screen I get the following text:
Quote:
Clockworkmod recovery v6.0.4.3
E: can't mount /cache/recovery/command
E: Failed closing /dev/block/platform/msm_sdcc.1/by-name/misco (I/O error)
E: Can't mount /cache/recovery/log
E: Can't open /cache/recovery/log
E: Can't mount /cache/recovery/last_log
E: Can't open /cache/recovery/last_log
E: Failed closing /dev/block/platform/msm_sdcc.1/by-name/misc (I/O error)
Then I go to "Instal zip" install from sideload:
Sideloading works in my command promt. I get 100%

In the phone this happens after the 100%:

Quote:
Restarting adb...
E: can't open /cache/recovery/last_install
E: faild to open last_install: No such file or directory
Finding update package...
Opening update package...
E: Can't open /tmp/update.zip (bad)
Installation aborted.
When i try to do factory reset I get

Quote:
--- Wiping data...
Formatting /data...
Error mounting /data!
Skipping format...
Formatting /cache...
Formatting /sd-ext...
Formatting /sdcard/.android_secure..
E: unknown volume "/sdcard/.android_secure"
Data wipe complete
E: can't mount /cache/recovery/log
E: Can't open /cache/recovery/log
E: can't mount /cache/recovery/last_log
E: can't open /cache/recovery/last_log
E: Failed closing /dev/block/platform/msm_sdcc.1/by-name/misc (I/O error)
So I figure something is wrong with my internal memory. Just guessing. That's why I need some input.
So my question is: What's causing this problems preventing me to flash the 4.4.2 stock rom?
Did I destroy some hardware?

Thanks for reading,

Semi
 
rirozizo
Old
#2  
rirozizo's Avatar
Recognized Contributor
Thanks Meter 1,183
Posts: 2,281
Join Date: Jul 2010
Location: wonderland... soon
yes, that's clearly a fried eMMC... since the recovery can't do anything about that, try flashing stock images via fastboot (because fastboot is "stronger"). if that didn't work, then... well... i hate to say it to a nexus user....

ISOCK youtube channel
ROM Specific Q&A/T Thread Template on the PORTAL

Get a (battery) Life!

Member of Slim Team (Support is never via PM)

Currently working on: Making XDA-TV videos, supporting slimroms IRC

Phone: Google Nexus4 LG E960 Mako 16GB Black | ROM: Latest Slimkat Build | Kernel: Changing | CPU: Never Overclocked | Recovery: TWRP/MultiROM
Dropbox link <--- click this to get extra space!

My Blog

 
 
seminarian
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Jun 2012
Quote:
Originally Posted by Riro Zizo View Post
yes, that's clearly a fried eMMC... since the recovery can't do anything about that, try flashing stock images via fastboot (because fastboot is "stronger"). if that didn't work, then... well... i hate to say it to a nexus user....
Thanks for the quick reply!

I've done "fastboot flash system stockrom" and In command prompt everything goes well until "FAILED: flash write failure"

The eMMC is on the motherboard and that costs 180 euro, not really worth it I guess to buy a new one. Is there any possibility that I made a mistake that's reversible by opening the nexus 4 again?


IF someone else could confirm this theory (which sounds credible) that I should replace my main board in order to get the phone working? No disrespect inteded to Riro Zizo, only want to be 100% sure. Thank you!
 
rirozizo
Old
#4  
rirozizo's Avatar
Recognized Contributor
Thanks Meter 1,183
Posts: 2,281
Join Date: Jul 2010
Location: wonderland... soon
sure! you can't be 100% sure until you get others' opinions and experience too... but i say there's no way that that can be fixed by reopening it. not even replacing the eMMC itself could work since the pins are just way too smal to work with.

sorry

Sent from my Nexus 4

ISOCK youtube channel
ROM Specific Q&A/T Thread Template on the PORTAL

Get a (battery) Life!

Member of Slim Team (Support is never via PM)

Currently working on: Making XDA-TV videos, supporting slimroms IRC

Phone: Google Nexus4 LG E960 Mako 16GB Black | ROM: Latest Slimkat Build | Kernel: Changing | CPU: Never Overclocked | Recovery: TWRP/MultiROM
Dropbox link <--- click this to get extra space!

My Blog

 
 
DrFredPhD
Old
#5  
Senior Member
Thanks Meter 40
Posts: 300
Join Date: Oct 2010
There's a small chance the new board isn't fitted quite right and it's shorting out or something, but most likely you've damaged something on the board during the repair.
 
seminarian
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Jun 2012
Quote:
Originally Posted by Riro Zizo View Post
sure! you can't be 100% sure until you get others' opinions and experience too... but i say there's no way that that can be fixed by reopening it. not even replacing the eMMC itself could work since the pins are just way too smal to work with.

sorry

Sent from my Nexus 4
No problem bro. Thank you.

Quote:
Originally Posted by DrFredPhD View Post
There's a small chance the new board isn't fitted quite right and it's shorting out or something, but most likely you've damaged something on the board during the repair.
Well yeah, it's the same board that I've moved. Too bad, lesson learned



I wonder one more thing.. When I was googling on possible causes someone somewhere, suggested that the guy needed to repartition his storage space or sth like that. Any chance that's a possible solution? Just to be 100% sure I can let it go LOL
 
Berrydroidcafe
Old
#7  
Berrydroidcafe's Avatar
Senior Member
Thanks Meter 230
Posts: 1,025
Join Date: May 2011
Location: Cleveland Ohio - San Diego Ca
Bummer! :-O I like tinkering and all, except my precious. There's two options, (for me) Service Center or new phone! So far, it's the new phone option that win the game. I know this doesn't help your present issue in one way, but it seems that you might not have a choice. Good luck to you.

Sent with my Nexus® 10 minus 3
Blackberry Bold 9780 OS 7
HTC G2 (Desire Z) 4.4.2
LG Nexus 4 4.4.2
Asus Nexus 7 (2013) 4.4.2

Don't forget to hit the Thanks button if I helped in any way!

 
DrFredPhD
Old
#8  
Senior Member
Thanks Meter 40
Posts: 300
Join Date: Oct 2010
You shouldn't need to flash a phone after a mechanical repair. I take it it still booted with the cracked screen? The fact that it doesn't now pretty much proves it's dead.
 
seminarian
Old
#9  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Jun 2012
Quote:
Originally Posted by DrFredPhD View Post
You shouldn't need to flash a phone after a mechanical repair. I take it it still booted with the cracked screen? The fact that it doesn't now pretty much proves it's dead.
Yeah that makes sense. Thanks alot guys. Appreciated.
 
silv3rfox
Old
#10  
silv3rfox's Avatar
Senior Member
Thanks Meter 33
Posts: 158
Join Date: Sep 2009
Location: Orsay
Freaking eMMCs! had a similar problem with flashing a dead phone, my GSII, ended up sending it to the repair center, luckily was still under warranty.
And about playing with PIT files, it's usually the hopeless case, but most of the time it doesn't work, and even if it does, the phone doesn't live afterwards much longer, the sd card still unstable.
I'm not an expert though but I guess it's a wise idea to let it go, and get a new android, maybe a N5?
A THANKS is always welcomed

Ex-Devices:
Sony Ericsson Xperia X1 - Went dead after I drowned in a river (True story)
iPhone 3G - Swapped for an XPERIA X10
Sony Ericsson XPERIA X10 - Gifted to my gf
HTC Sensation - Sold
Samsung i9100 GSII - Bricked, repaired then sold
HTC One X - Sold
Sony XPERIA Z - Sold

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes