FORUMS

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

[Q]PC cannot detect my Nexus4

321 posts
Thanks Meter: 34
 
By ryo2456, Senior Member on 9th July 2014, 12:10 PM
Post Reply Subscribe to Thread Email Thread
15th July 2014, 07:42 PM |#21  
Member
Ft. Benning
Thanks Meter: 2
 
More
Quote:
Originally Posted by ryo2456

yes I think my USB PORT is done too. so I decide to repair it by myself because the fee is about HKD $200...

I don't think it's your USB port nor your phone, it's the computer and drivers. Try what's in these threads;
http://forum.xda-developers.com/nexu...orage-t2424733
http://forum.xda-developers.com/nexu...t2287768/page2

I did all that and still no connection then I did this:
I opened up device manager and had a portable device < Nexus 4 listed w/a yellow triangle. then in another window I ran the WUG Toolkit and picked root. WUG told tried to work but gave me the error page that said I was not connected or turn on debugging etc. I went back to device manager and had to r/click on my device to bring up properties picked the driver tab and then the update driver choice. Right away, with doing nothing else, an android device populated the list and I went back to WUG clicked ok on the error message, telling it to root my device. Sure as hell after 4 days WUG rooted my device successfully and as it finished I had a message pop up on my taskbar telling me that the Google Nexus 4 drivers had successfully loaded. The root process had rebooted my phone so thats why I got the message, I think.

And now all is good in the hood.
 
 
15th July 2014, 07:52 PM |#22  
ryo2456's Avatar
OP Senior Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by ahunter

I don't think it's your USB port nor your phone, it's the computer and drivers. Try what's in these threads;
http://forum.xda-developers.com/nexu...orage-t2424733
http://forum.xda-developers.com/nexu...t2287768/page2

I did all that and still no connection then I did this:
I opened up device manager and had a portable device < Nexus 4 listed w/a yellow triangle. then in another window I ran the WUG Toolkit and picked root. WUG told tried to work but gave me the error page that said I was not connected or turn on debugging etc. I went back to device manager and had to r/click on my device to bring up properties picked the driver tab and then the update driver choice. Right away, with doing nothing else, an android device populated the list and I went back to WUG clicked ok on the error message, telling it to root my device. Sure as hell after 4 days WUG rooted my device successfully and as it finished I had a message pop up on my taskbar telling me that the Google Nexus 4 drivers had successfully loaded. The root process had rebooted my phone so thats why I got the message, I think.

And now all is good in the hood.

there are no resopnse when I plug in the Nexus. I'm pretty sure that my phone USB port is done, although it can charge.

My device didn't show in the device manager, no Nexus 4, no Yellow triangel.
Last edited by ryo2456; 15th July 2014 at 09:29 PM.
15th July 2014, 10:17 PM |#23  
Member
Ft. Benning
Thanks Meter: 2
 
More
Quote:
Originally Posted by ryo2456

there are no resopnse when I plug in the Nexus. I'm pretty sure that my phone USB port is done, although it can charge.

My device didn't show in the device manager, no Nexus 4, no Yellow triangel.

Your right I missed the "No response" when you plug in. Even at my worst when I plug in the computer tried to & failed to load drivers.
16th July 2014, 04:25 AM |#24  
ryo2456's Avatar
OP Senior Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by ahunter

Your right I missed the "No response" when you plug in. Even at my worst when I plug in the computer tried to & failed to load drivers.

Yeah, my computer didnt know I plug in my device.....
16th July 2014, 04:45 AM |#25  
Senior Member
Thanks Meter: 110
 
More
Consider installing Nexus 4 Naked Drivers.

http://forum.xda-developers.com/nexu...naked-t1996051

They'll install/override your current driver configuration and hopefully your computter will detect your phone again.
17th July 2014, 11:29 AM |#26  
ryo2456's Avatar
OP Senior Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by sky0165

Consider installing Nexus 4 Naked Drivers.

http://forum.xda-developers.com/nexu...naked-t1996051

They'll install/override your current driver configuration and hopefully your computter will detect your phone again.

No, my computer can't detect my Nexus
17th July 2014, 05:45 PM |#27  
Senior Member
Thanks Meter: 110
 
More
Format your computter then.
17th July 2014, 06:03 PM |#28  
maulich's Avatar
Senior Member
Flag Carmichael, CA
Thanks Meter: 175
 
More
Have the same problem on my win7 PC. Won't see phone until I enable USB debugging. Laptop and other PCs work fine so I think its a driver issue.
22nd July 2014, 05:46 PM |#29  
ryo2456's Avatar
OP Senior Member
Thanks Meter: 34
 
More
After I replace a new USB Port of my Nexus4, the PC can detect my Phone.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes