FORUMS

Earthquake Early Warning in Your Pocket

Probably all of us reading this have a smartphone in our pocket. For many of us, the … more

Sony: The OEM You Want To Save

In our recent Discuss article, we asked you readers on which OEM you would like to help. While the … more

How to Lock and Protect Your Apps – XDA Xposed Tuesday

The smartphone revolution has passed. Everybody has mobile apps. Some of … more

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

[Q] stock nexus 4 stuck on boot "X" animation after OTA update to 4.4

4 posts
Thanks Meter: 0
 
By xxxxxda, Junior Member on 13th April 2014, 06:24 AM
Post Reply Subscribe to Thread Email Thread
i have a stock nexus 4 bought last year from a relative, when they tried to do an OTA update to (i think 4.4) it restarted and gave an error with the android being open in the middle. After restarting the phone it's been stuck in the "X" bootup screen

i tried to clear cache partition and that didn't work.
i got the android sdk and tried to connect it to the computer. it was recognized as an android bootable device in the device manager, but nothing shows up in the file manager, and when i tried to run the "adb device" command no devices show up.

i guess my question is, is there a way for me to pull the data from the phone first before i do the flashing? i heard that if i get rid of the "-w" in the flash-all.sh/flash-all.bat then it'll prevent the data wipe, is that also true?

thanks for the help!
 
 
13th April 2014, 08:52 AM |#2  
krishnanmailbox1's Avatar
Senior Member
Flag hyderabad
Thanks Meter: 41
 
More
looks like u didnt install the drivers properly... update them first... or reinstall all the drivers... thankyou..

Sent from my LG-E975 using XDA Premium 4 mobile app
14th April 2014, 04:03 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by krishnanmailbox1

looks like u didnt install the drivers properly... update them first... or reinstall all the drivers... thankyou..

Sent from my LG-E975 using XDA Premium 4 mobile app

which driver? i also downloaded the google usb driver from android sdk and restarted computer a couple times

thanks
16th April 2014, 11:11 AM |#4  
krishnanmailbox1's Avatar
Senior Member
Flag hyderabad
Thanks Meter: 41
 
More
After downloading sdk tools you need to install couple of drivers from sdk... Open sdk and check onece if you have drivers installed properly

Sent from my LG-E975 using XDA Premium 4 mobile app
17th April 2014, 06:41 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by krishnanmailbox1

After downloading sdk tools you need to install couple of drivers from sdk... Open sdk and check onece if you have drivers installed properly

Sent from my LG-E975 using XDA Premium 4 mobile app

yeah, i did that and installed the usb driver, but it only shows up in device manager as "other device" and i can't access it. I guess i'll just factory reset and lose all my data haha... next time i'll know to always back up
18th April 2014, 07:40 AM |#6  
OP Junior Member
Thanks Meter: 0
 
More
i ended up unlocking the phone with

>>fastboot oem unlock

then ran the flash-all.bat file(on windows) and flashed it to 4.3 and it works now (no problems for now..)
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes