5,600,664 Members 37,355 Now Online
XDA Developers Android and Mobile Development Forum

[Q] TWRP failed

Tip us?
 
dreammaster252
Old
(Last edited by dreammaster252; 22nd November 2013 at 02:53 PM.)
#1  
Member - OP
Thanks Meter 1
Posts: 42
Join Date: Aug 2012
Location: Lexington
Default [Q] TWRP failed

I get a failure when trying to flash a new ROM. I have three different zips (ROMs) on my phone. None of them will install for some reason and I get a failed error and it puts something about an error when updating binary script? How could I fix this on my nexus 4?
If I need to update twrp could I do so without using goomanager to do this? Goomanager won't download the recovery so I have to use another method
 
eksasol
Old
(Last edited by eksasol; 22nd November 2013 at 05:52 PM.)
#2  
Senior Member
Thanks Meter 665
Posts: 2,657
Join Date: Nov 2009
You probably need to update to the latest TWRP version. Use the TWRP link in my signature and get the latest version in the "mako" folder.

Use fastboot to flash it, use the command:
fastboot flash recovery twrp.img

(replacing twrp.img with actual file name)

If you don't know how to use fastboot, use the 3rd link for guide on installing custom recoveries.
 
thenobol
Old
(Last edited by thenobol; 23rd November 2013 at 12:14 PM.)
#3  
Senior Member
Thanks Meter 126
Posts: 164
Join Date: Nov 2013
Quote:
Originally Posted by dreammaster252 View Post
I get a failure when trying to flash a new ROM. I have three different zips (ROMs) on my phone. None of them will install for some reason and I get a failed error and it puts something about an error when updating binary script? How could I fix this on my nexus 4?
If I need to update twrp could I do so without using goomanager to do this? Goomanager won't download the recovery so I have to use another method
had the same error and resolved it like this:

installed ROM Installer vom play store
installed cwm, and then twrp again from rom installer.. worked perfectly!

BUT WHATCH OUT! i think the error you get is called "error 9".. or something like that, it appears, when you try to install a zip, and the updater-skripts cancels the installation process, e.g., because it is not hte right zip for your phone!

so look at first, if you have the right zip downloaded
Keep Calm, and push the THANKS button
Nexus 5
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes