FORUMS

Android M Preview Images – XDA TV

Android M preview images are available. That and much more news is covered by Jordan when he … more

I/O Summary: How Android M Handles Power And Charging

In the spirit of improving the core Android experience, Google is changing Android … more

I/O Summary: Google Photos App

At I/O 2015, Google tackled the information problem in mobile once more, this time through … more

I/O Summary: Development, Play Store, The Next Billion

VP of Engineering Jen Fitzpatrick began talking about what Google is doing to … more

[Q] usb port replaced -> battery drain(slimport wakelock)

Thanks Meter: 3
 
By karar2012, Junior Member on 30th March 2014, 06:29 PM
Post Reply Subscribe to Thread Email Thread
Hey everybody,

about 2 weeks ago I had to change the USB port on my nexus 4 because It wasn't charging. I went to a professional place and they replaced it. everything worked fine but I did notice a significant battery drain. poking around with several battery apps revealed that the culprit is "slimport wake lock". further digging around revealed that what probably happened is that during the replacement of the USB port, something now malfunctions with the slimport chip/connection and it stays constantly on.

I of course plan on taking the device to the laboratory and have the guy there take a look at it. unfortunately there's very little on the subject wherever i looked and I was wondering if any of you had something similar that can help me point the guy there. Also, I was wondering if there's any way to SHUT DOWN the slimport option (as I don't even use it) via the OS, developer options, some app or something else.

any help would be appreciated

SS of slimport wakelock being awake constantly is attached
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-03-24-08-34-59.png
Views:	123
Size:	189.5 KB
ID:	2659268   Click image for larger version

Name:	Screenshot_2014-03-24-08-34-59.png
Views:	123
Size:	189.5 KB
ID:	2659268  
Last edited by karar2012; 30th March 2014 at 06:52 PM. Reason: adding ss
 
 
21st May 2014, 12:13 AM |#2  
GruZone's Avatar
Senior Member
Flag Ashkelon
Thanks Meter: 107
 
More
Quote:
Originally Posted by karar2012

Hey everybody,

about 2 weeks ago I had to change the USB port on my nexus 4 because It wasn't charging. I went to a professional place and they replaced it. everything worked fine but I did notice a significant battery drain. poking around with several battery apps revealed that the culprit is "slimport wake lock". further digging around revealed that what probably happened is that during the replacement of the USB port, something now malfunctions with the slimport chip/connection and it stays constantly on.

I of course plan on taking the device to the laboratory and have the guy there take a look at it. unfortunately there's very little on the subject wherever i looked and I was wondering if any of you had something similar that can help me point the guy there. Also, I was wondering if there's any way to SHUT DOWN the slimport option (as I don't even use it) via the OS, developer options, some app or something else.

any help would be appreciated

SS of slimport wakelock being awake constantly is attached

Did u manage to solve this issue mate?

Sent from my Nexus 4 using Tapatalk
21st May 2014, 04:56 AM |#3  
Senior Member
Thanks Meter: 181
 
More
slimport is to connect to an external display via usb like MHL cable, i read that the usb hardware can be the reason, the guy replaced the usb port again in the links below.

make a cwm backup, and flash android again install betterbatterystats and see if the wakelock continues if so you should replace the usb port.

theory, the slimport pin is touching another?

http://www.reddit.com/r/nexus4/comme..._battery_life/

http://www.reddit.com/r/nexus4/comme...to_improve_it/
21st May 2014, 06:02 PM |#4  
Senior Member
Thanks Meter: 40
 
More
Part is copy/faulty, see if they'll change it for another for you.
27th June 2014, 06:59 PM |#5  
OP Junior Member
Thanks Meter: 3
 
More
USB port was changed again, also did:
-Factory Reset
-updated to 4.4.3(and yesterday - 4.4.4)
-Battery change

No dice. I gave up and bought myself a Moto G.
Though, if anyone comes across a solution - do tell.
27th June 2014, 10:15 PM |#6  
Junior Member
Flag Stockton-on-Tees
Thanks Meter: 0
 
More
Seems to me like broken USB port or pinout not compatible. Possibly they did short-circuit on one circuit on PCB. What I can advise is go back to people who changed USB port and ask them to re-solder everything by using compatible parts.

Kind regards,
29th June 2014, 06:15 PM |#7  
GruZone's Avatar
Senior Member
Flag Ashkelon
Thanks Meter: 107
 
More
I have the solution guys... Though its hard to explain, its not very hard to accomplish.
I took my n4 for another try in a different lab. The technician from the start suspected it's not something in the charging port itself, so he asked me to leave the phone for him for a few days.
After 4 days of trying and learning, he managed to find that the problem is in the socket on the board itself is causing the problems, along with the charging port, in my case.
He replaced the port on the board itself and the problem is solved.
Eventually, I paid 40 for this problem, not very high, beats the other option (buying a new phone)

Try it guys.

---------- Post added at 06:15 PM ---------- Previous post was at 06:15 PM ----------

If anyone needs another explanation don't hesitate to contact via hangouts.
avishvili@gmail.com.com
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes