Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,304 Members 41,301 Now Online
XDA Developers Android and Mobile Development Forum
View Poll Results: Is your Nexus 4's wifi reliable?
Yes, it works everywhere. 13 72.22%
No. unusable. 5 27.78%
Voters: 18. You may not vote on this poll

[Q] Wifi and me - not happening! Piece of CRAP google!

Tip us?
 
newuser02
Old
(Last edited by newuser02; 11th February 2013 at 01:39 AM.) Reason: spelling
#1  
Member - OP
Thanks Meter 11
Posts: 73
Join Date: Oct 2010
Location: Concord, CA
Sign [Q] Wifi and me - not happening! Piece of CRAP google!

I'm sure I'm not alone in this.
My N4 won't connect to wifi. Well it connects but Won't keep a connection to complete a playstore app install nor update the system itself?

This is what I posted on "Issue 40065: Nexus 4 and Nexus 7 Wifi Drops connection Android 4.2"
Quote:
New device just received. Will connect to wifi but unable to install any apps thru play store.... Just shows data transferring but none actually happens. I'm unable to install none of the gapps updates. Left it alone for 2 days did not help. removing password from router and making it an open router did not help. Now trying to decide I should return the device as it is only usable as a phone not a multimedia device which this N4 should be?
There are a lot of people having the same kind of issue on this phone. A little search brings up lots and lots of complaints.
Still unable to connect to my router encore model 2AN3.
Tried to connect to open wifi router at McD and Star!@#$ - still no go. It will connect think about it and stops. The icon at the top turns green and gray and keeps doing it.
How ever I was able to connect to the open wifi router on another Nexus S (my older phone) and was able to download updates and install said applications from play store.

This tells me that hardware is good. Software coded so badly that it is unable to keep a connection to routers.

So if you need to use this phone on a wifi router - wait until google fix this or get another phone.
As for me - it is a shame I will have to return this phone to google as it is useless media device. Just a phone which I can get a cheap phone for 10 bucks not $400 piece of sh!@#$%T.

Sorry for the RANT.
Also flashed rom CM10.1 stable and xylon 17 stable. Still same problem repeated. both ROMS can connect to my hotspot on my NS but unable to neither my home router nor public wifi.

A few things I have tried.
1. avoid poor wifi disabled.
2. switch chennels to 6 or 8 - tried all.
3. Resetting routers
4. Assigning static IP address
5. Cleared cache from recovery
6. changed the Wi-Fi band from 'Auto' to 2.4Ghz and 5Ghz
7. Flashed new kernel Running franko.
8. Flashed 2 other ROMS/cm10.1 and xylon17 both stable versions.

My home router have not trouble connecting to all other devices at home (NS, HP touchpad, 3 desktop and 3 other laptops, Tried with N4 being the only device that was turned on. : still no go!! WHY WHY WHY WHY WHY!!!

Also followed the directions from this thread. Still no candy.

Please take a poll and let post here if you should find a good solution.
 
americasteam
Old
#2  
americasteam's Avatar
Senior Member
Thanks Meter 338
Posts: 1,187
Join Date: Jan 2011
Location: Bowling Green, KY
Default [Q] Wifi and me - not happening! Piece of CRAP google!

Mine works flawlessly. You should contact Google for a RMA.

Sent from my iPad using Tapatalk HD
 
krishnabhargavt
Old
#3  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Feb 2012
Location: Hyderabad
I guess its the lease period on your router that you need to change... put it to lease expiring n a day or two... shuld work.. I had this issue when I upgraded to 2.3.6 on my Atrix
 
newuser02
Old
#4  
Member - OP
Thanks Meter 11
Posts: 73
Join Date: Oct 2010
Location: Concord, CA
Quote:
Originally Posted by krishnabhargavt View Post
I guess its the lease period on your router that you need to change... put it to lease expiring n a day or two... shuld work.. I had this issue when I upgraded to 2.3.6 on my Atrix
Tried that and also assigned a static ip. No joy!
Thanks for the advice.

Quote:
Originally Posted by americasteam View Post
Mine works flawlessly. You should contact Google for a RMA.

Sent from my iPad using Tapatalk HD
I just called. This guy treated me like I'm noob. But I digress.. He asked me to turn off GPS and try again saying that GPS and wifi together can not be on at the same time. That still did not work. So there is a request for replacement. Not really sure when I will get it. But keep my finger crossed - that I get a working wifi and gps at the same time ??

Don't really want to return it though since I like the phone form factor and such!

What a shame.
 
Caesarivs
Old
#5  
Caesarivs's Avatar
Senior Member
Thanks Meter 98
Posts: 293
Join Date: Feb 2012
Location: Medellín

 
DONATE TO ME
Quote:
Originally Posted by newuser02 View Post
I just called. This guy treated me like I'm noob. But I digress.. He asked me to turn off GPS and try again saying that GPS and wifi together can not be on at the same time. That still did not work. So there is a request for replacement. Not really sure when I will get it. But keep my finger crossed - that I get a working wifi and gps at the same time ??
Why wouldn't WiFi and GPS work together? I don't see any reason as to why one would interfiere with another
 
theabsurdman
Old
#6  
Senior Member
Thanks Meter 34
Posts: 239
Join Date: May 2010
Quote:
Originally Posted by newuser02 View Post
I'm sure I'm not alone in this.
My N4 won't connect to wifi. Well it connects but Won't keep a connection to complete a playstore app install nor update the system itself?

This is what I posted on "Issue 40065: Nexus 4 and Nexus 7 Wifi Drops connection Android 4.2"
Also flashed rom CM10.1 stable and xylon 17 stable. Still same problem repeated. both ROMS can connect to my hotspot on my NS but unable to neither my home router nor public wifi.

A few things I have tried.
1. avoid poor wifi disabled.
2. switch chennels to 6 or 8 - tried all.
3. Resetting routers
4. Assigning static IP address
5. Cleared cache from recovery
6. changed the Wi-Fi band from 'Auto' to 2.4Ghz and 5Ghz
7. Flashed new kernel Running franko.
8. Flashed 2 other ROMS/cm10.1 and xylon17 both stable versions.

My home router have not trouble connecting to all other devices at home (NS, HP touchpad, 3 desktop and 3 other laptops, Tried with N4 being the only device that was turned on. : still no go!! WHY WHY WHY WHY WHY!!!

Also followed the directions from this thread. Still no candy.

Please take a poll and let post here if you should find a good solution.
You shouldn't be flashing ROMs to try and fix something as basic as this. You're only adding more variables to the problem. My WiFi has been rock solid, and so apparently is that of most other posters. This would tend to indicate that there is a specific problem with your phone.
Unless there is something seriously wrong with your router it's RMA time I reckon.
 
newuser02
Old
#7  
Member - OP
Thanks Meter 11
Posts: 73
Join Date: Oct 2010
Location: Concord, CA
Quote:
Originally Posted by theabsurdman View Post
You shouldn't be flashing ROMs to try and fix something as basic as this.
I see your point and I agree.
But after a full day of fiddling with it on stock ROM, what the hell not?
Quote:
You're only adding more variables to the problem.
I sure did! But I also tried a couple of other fixes I have found on the web and on this forum. That did not help either.
Quote:
My WiFi has been rock solid, and so apparently is that of most other posters. This would tend to indicate that there is a specific problem with your phone.
Unless there is something seriously wrong with your router it's RMA time I reckon.
I reckon, I will.
Just to re-iterate .....
Wifi works if I connect to my other nexus S's hot spot.
Wifi will not stay connected to allow me to go to play store on any wifi router (home Encore ENHWI-2AN3 firmware version 1.1.3 - Mcdee's open wifi and Starb!@#'s open wifi router.) It will connect - get a blue wifi icon with a few arrows ..... but will go to gray and back to blue and so on ....

Waiting for google to make up its mind about shipping me a replacement.

:=(

 
calyxim
Old
#8  
calyxim's Avatar
Senior Member
Thanks Meter 65
Posts: 407
Join Date: May 2011
Location: London
Default Re: [Q] Wifi and me - not happening! Piece of CRAP google!

You are alone on this.
Now get a refund and buy an iphone.

Tags
nexus 4, sucks, unusable, wifi
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Change Your Toast Notification Style with XToast

Android uses multipletypes of notifications. One of these isknown as a toast notification. … more

Port Sony Xperia Themes to CyanogenMod 11 with Ease

In addition the obvious proficiency with graphics, creating agood Android theme … more

Cell Phone SIM Unlock Bill Just Steps Away from President’s Desk

For all those who believe that Cinderella stories don’t actually … more