Post Reply

Wifi stuck on "Turning on", even after reflash

OP liveangelic

2nd September 2014, 10:15 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: May 2011
Greetinga, xda denizens!

So I tried the LTE Flasher App for my Nexus 4, flashing hybrid modem files in order to enable LTE on my phone, but since then everything seems to be broken about my phone and most importantly wifi is stuck in turning on.

I tried factory resetting and flashing new kernel (Cyanogen 10.2) but that didn't help.

Is there something else I can do? I thought that wiping and reflashing is the most brutal thing you can do to fix what's wrong with your device.

Thanks for any help,
Adam
2nd September 2014, 04:31 PM   |  #2  
Marvlesz's Avatar
Senior Member
Flag Saudi Arabia
Thanks Meter: 742
 
2,306 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by liveangelic

Greetinga, xda denizens!

So I tried the LTE Flasher App for my Nexus 4, flashing hybrid modem files in order to enable LTE on my phone, but since then everything seems to be broken about my phone and most importantly wifi is stuck in turning on.
Adam

Flashing a kernel doesn't flash modem, you need to do that manually. Download a stock modem from xda/google and flash it using fastboot. I don't know if it's related to wifi or not, but it's worth a shot.
2nd September 2014, 09:08 PM   |  #3  
Oxious119's Avatar
Senior Member
Thanks Meter: 52
 
321 posts
Join Date:Joined: Apr 2013
Yup. If the radio you flashed is faulty a factory reset/ROM reflash/kernel reflash won't change a thing. The radio is a separate partition and 99% of all Roms come without a radio partition. As mentioned above, download a stock radio from here and flash it. Should fix the issue.

Sent from my Nexus 4 using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes