Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,798 Members 49,702 Now Online
XDA Developers Android and Mobile Development Forum

WIFI Tether Issue

Tip us?
 
jrosetto
Old
#1  
Senior Member - OP
Thanks Meter 35
Posts: 219
Join Date: May 2012
Location: Clearwater
Default WIFI Tether Issue

So the internet went out today and I though... Why don't I use my phone as a hotspot until it comes back up. After enabling native tethering I connected my laptop to it and it got an IP. I opened my homepage (google.com) and it loaded. After that I did a search on google and it worked. Then I clicked the link and it didn't go anywhere. I thought it was a server down or something so I clicked on another link and the same thing happened. After messing around with it some more I found that anything google related... the play store, youtube worked find but no other site would load. I decided to flash a different rom because I though that was the culprit but it didn't make any difference. I do have the LTE modem installed and franco kernel. Anyone have any suggestions on how to fix this?
 
Fhuron
Old
#2  
Junior Member
Thanks Meter 2
Posts: 12
Join Date: Jul 2013
Go into your network setting , Find your APN under Mobile Networks and check to see if you are using IPv6. If you are, change it to IPv4 if you can. This may or may not be possible depending on the ROM you are using, this was what got it working on the CM11 based ROM I use. Some evidently require the use of an SQL editor.

Good Luck
The Following 2 Users Say Thank You to Fhuron For This Useful Post: [ Click to Expand ]
 
jrosetto
Old
#3  
Senior Member - OP
Thanks Meter 35
Posts: 219
Join Date: May 2012
Location: Clearwater
Quote:
Originally Posted by Fhuron View Post
Go into your network setting , Find your APN under Mobile Networks and check to see if you are using IPv6. If you are, change it to IPv4 if you can. This may or may not be possible depending on the ROM you are using, this was what got it working on the CM11 based ROM I use. Some evidently require the use of an SQL editor.

Good Luck
Spot on my friend. APN protocol was on IPv6 and APN roaming protocol was on IPv4. I changed APN protocol to IPv4 and it is working great. Thanks for the help. Was pulling my hair out on this one.
The Following User Says Thank You to jrosetto For This Useful Post: [ Click to Expand ]
 
Bobrt
Old
#4  
Bobrt's Avatar
Member
Thanks Meter 2
Posts: 39
Join Date: Jul 2009
ditto
worked for me
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes