Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Bootloop after downgrade from L Preview..

OP DavidTiger

12th August 2014, 07:40 AM   |  #1  
OP Senior Member
Flag Kirkcaldy
Thanks Meter: 42
 
206 posts
Join Date:Joined: Nov 2008
Donate to Me
More
Hey, I have an issue with my tablet after I wanted to go back to kitkat from the L Preview.

I had 4.4.4 and decided I'd like to try out the L preview
So I downloaded the img from Google and flashed it via fastboot, worked perfectly fine but not as stable in apps as it was on kk.
So, I downloaded the latest factory image from the Google Developer Site, extracted it and ran the flash_all.bat
Seemed to flash ok, no errors, rebooted and started to boot but it only goes as far as the spinning boot logo. No further.
After leaving it a good hour or so I decided it clearly wasn't going to boot I went back into the bootloader and tried to get into stock recovery mode but after rebooting it just stays at the white Google logo..
So, I tried to flash TWRP via fastboot. Again no errors, successful flashed but just like before it sticks at the Google logo and never boots the recovery..
I even tried the "fastboot boot recovery.img" but then it just freezes on the bootloader.
I've also tried the 4.4.3 img.. same happens.

Now if I reflash the L Preview img via fastboot it sticks at the Google logo and didn't even reach the boot logo!

Sounds to me like the partitions have gotten corrupt? Though the imgs are flashing successfully without error so I don't think it's that..
But.. recovery partition is broken as I can't get into recovery at all, and it freezes if I try.

Anyone any idea what could have happened?
All I did was flash the KK factory image over L, just like I flashed L over KK and it worked fine.
All the guides online do the same thing to downgrade L to KK.

Is it bricked? Can it be recovered?
I still have bootloader access with fastboot..

Any help is greatly appreciated!
Last edited by DavidTiger; 12th August 2014 at 07:49 AM.
13th August 2014, 02:01 AM   |  #2  
OP Senior Member
Flag Kirkcaldy
Thanks Meter: 42
 
206 posts
Join Date:Joined: Nov 2008
Donate to Me
More
I finally managed to enter the stock recovery and it appears that the /cache partition was damaged or corrupt. Strangely it would get corrupted each time I flashed the factory image, even flashing the cache.img directly..
However it seems to have fixed by doing a factory reset and /cache then formats correctly and android booted fine after this


As you see in the image, when entering recovery I was presented with a bunch of errors regarding the cache.
Tried to wipe cache but that fails.
Did a factory reset and cache seemed to format fine.
Did another wipe cache and this time it completes without the error I got before.
Then rebooted, Android began booting and thankfully it's now working fine again!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes