Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

every game lags and stutters on new nexus 7

OP masterx1234

1st September 2014, 06:25 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Sep 2014
so i just got a brand new nexus 7 2nd gen last week and so far i love it but nearly every game is suffering from what i can understand as "stuttering" or "microstutter". its as if the games just dont play smooth, several games hitch and lag when there is alot of movement on the screen, i am on the latest version of android (kitkat 4.4.4) and my device is rooted, but this issue even still affected the tablet even before the root. So what on earth could cause my games to stutter and lag like they do?? also i have tried disabling google currents entirely and that did nothing. so do any of you android users out there know anything i can do to fix the lag in my games? also my nexus 7 also seems to be suffering from random reboots as well. I am certain it is a software issue and not the tablet itself, because i have read that many other users of this tablet are having the exact same problem after updating to kitkat 4.4.4, Please try to make your replies as simple as possible because im a total noob in this whole android stuff and im just getting into hacking and tweaking my first ever android tablet.
7th September 2014, 10:51 PM   |  #2  
Diljinder's Avatar
Member
Thanks Meter: 3
 
33 posts
Join Date:Joined: Oct 2010
Donate to Me
More
I'm suffering extremely Jerky scrolling issue in different apps.

I was also quite excited about this purchase made just a few weeks ago. Can't be more disappointed.

You can try an app called "lag fix". It'll TRIM your storage. It made a huge difference in previous Nexus 7, but I didn't notice any difference whatsoever in my case on Nexus 7 2013.

This will be effectively my last Asus product.
9th September 2014, 12:29 AM   |  #3  
mugzylol's Avatar
Member
Thanks Meter: 8
 
90 posts
Join Date:Joined: Jun 2014
I have had NONE of these problems on mine. I love mine and it works great for me. You should definitely try a hard reset because they usually work quite well on things like this.

sent from my nex7
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes