FORUMS

Analysis & Opinion

Top Forum Discussions

OTG not working

5 posts
Thanks Meter: 0
 
By paeminem, Junior Member on 25th May 2015, 04:32 PM
Post Reply Subscribe to Thread Email Thread
So Ive run into a strange problem. I was watching a movie last night on my nexus, the file was on my usb drive connected via otg to the nexus. Today I try to do the same and I get no reaction from Stickmount when plugging in the drive. I have no problems charging or connecting the tablet to my PC, and the drive works fine both connecting to the PC and to my smartphone with stickmount as well. I also tried DLing an app called OTG Troubleshooter to see if that would help me. When connecting the drive it tells me that OTG is detected, but that "Mass storage USB device is not detected in linux/android". Does anyone know what the problem is?

Thanks in advance
 
 
25th May 2015, 06:41 PM |#2  
Member
Thanks Meter: 4
 
More
Nexus Media Importer
I had a similar problem with the device not recognizing the OTG cable, it went away after I installed the Nexus Media Importer.
25th May 2015, 08:05 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Cazteclo

I had a similar problem with the device not recognizing the OTG cable, it went away after I installed the Nexus Media Importer.

I tried with Nexus Media Importer as well, no success there either, it doesnt detect the drive. Thanks for the tip anyway
27th May 2015, 12:45 PM |#4  
Member
Flag Cape May Court House
Thanks Meter: 9
 
More
mine does the same thing with both stickmount and nexus media importer, I even tried 3 different OTG cables and flashdrives and get the same results
28th May 2015, 03:19 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by gmfirebird

mine does the same thing with both stickmount and nexus media importer, I even tried 3 different OTG cables and flashdrives and get the same results

Same here, maybe somethings wrong with the nexus' usb port?
31st May 2015, 01:17 PM |#6  
Member
Flag Cape May Court House
Thanks Meter: 9
 
More
Quote:
Originally Posted by paeminem

Same here, maybe somethings wrong with the nexus' usb port?

mine usually recognizes the cable, it is the thumb drive attached to it that it usually dosent see
31st May 2015, 03:26 PM |#7  
Member
tokyo
Thanks Meter: 1
 
More
im no expert but i was having issues with a physical keyboard through otg
on stock rom it times out
im on cm12 may 30 2015 with elementalx kernel
after flashing i plugged in the otg with the wireless keyboard reciever
nothing. worse than stock.
i downloaded all the usb otg helpers etc what not
in conclusion
i somehow managed to get
s3c usb host drivers for android
installed them from some site that i cant remember anymore -- really dumb --. seemed sketchy but had nothing to lose
altought now i can type still getting the same crap problmes i had with stock but not as bad. time s out
Last edited by ichiai; 31st May 2015 at 03:27 PM. Reason: missing info
2nd June 2015, 09:28 PM |#8  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by gmfirebird

mine usually recognizes the cable, it is the thumb drive attached to it that it usually dosent see

I have the same problem and have just tested that connecting a mouse or keyboard to the otg works without problems, what doesnt work is a flash drive. ( I have tried different flash drives to no success)

Does anyone know what the problem might be?
4th June 2015, 07:34 PM |#9  
Member
Flag Cape May Court House
Thanks Meter: 9
 
More
Quote:
Originally Posted by paeminem

I have the same problem and have just tested that connecting a mouse or keyboard to the otg works without problems, what doesnt work is a flash drive. ( I have tried different flash drives to no success)

Does anyone know what the problem might be?

I uninstalled and then reinstalled it again and now it is working again. I think it might have been slow to update
9th June 2015, 07:12 PM |#10  
Junior Member
Thanks Meter: 4
 
More
Maybe you guys are using a Kernel with OTG+Charge option? if yes the problem maybe that you have to connect the AC charger and USB device together. If you don't need the OTG+charge you should deactivate that function.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes