Post Reply

[Q] Touchscreen registering touches automatically !!

OP Slasher_44

8th July 2014, 03:15 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Mar 2014
More
Hi

I have a nexus 7 2012 running on Android 4.4.3 . My issue is that touches are automatically getting registered without me pressing the display . It mainly happens in the back button area , so its very irritating . I tried soft reset , full factory reset , software update and touch calibration with an app available in xda . But it still reoccurs .

Can some one suggest any other methods ?
9th July 2014, 12:04 AM   |  #2  
kcipopnevets's Avatar
Senior Member
Flag Staten Island
Thanks Meter: 30
 
211 posts
Join Date:Joined: Oct 2013
More
Quote:
Originally Posted by Slasher_44

Hi

I have a nexus 7 2012 running on Android 4.4.3 . My issue is that touches are automatically getting registered without me pressing the display . It mainly happens in the back button area , so its very irritating . I tried soft reset , full factory reset , software update and touch calibration with an app available in xda . But it still reoccurs .

Can some one suggest any other methods ?

This could be a hardware problem. Phantom touches should NOT be happening out of the blue.
21st July 2014, 02:23 PM   |  #3  
Junior Member
Thanks Meter: 2
 
9 posts
Join Date:Joined: Aug 2012
It happens to me too on my grouper Nexus 7 2012, mainly in the center-right of the screen. I activated the option to see the input and I can clearly see it.

I know the most obvious cause of this is hardware issue but the strange thing is that mine does it only after a certain time without a reboot. As soon as I reboot it stops for a while. So I guess it's not 100% hardware or caused by overheating. And if I just put it aside instead of rebboting it the minute I wake it from sleep the problem is still there, only a reboot can help. And it doesn't do it on the recovery.

The other thing I should mention is that I have issue with the headphones on the tablet and I have to "twist" lightly near the connector to make the sound play on both channels. This is a known hardware issue. I had the touchscreen problem before that so the "twisting" is not the cause of it (and again since a reboot makes the problem go away I guess that's not it)

I tried many roms with the same problem and it happens only since I have f2fs (must be a coincidence) and I am now on 4.4.4 saberdroid and I have the same issue.


Is there a possibility that it could be anything else beside hardware???.... I will try 100% stock soon but I wanted to find if anyone had ideas about this...

Thanks! (if it doesn't work I might have to buy a Shield tablet, poor me!)
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 7 Q&A, Help & Troubleshooting by ThreadRank