Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,683 Members 51,010 Now Online
XDA Developers Android and Mobile Development Forum

OmniRom 4.4.4 Unofficial Nexus S 4G, Build - 1th July 2014

Tip us?
 
Setting.Out
Old
#141  
Setting.Out's Avatar
Senior Member
Thanks Meter 1,214
Posts: 1,912
Join Date: Mar 2013
Location: Asnieres-Sur-Seine
Quote:
Originally Posted by mathuaerknedam View Post
I've been able to use Marmite 10.6, Matr1x 25 cfs and bfs, and Devil Kernel 20131025_VC. When I flash Devil kernel I see the odd message "Making marmiteInstalling Devil kernel", but it seems to work. However, neither of the Devil kernel apps I tried would recognize that Devil was running.

I tried flashing Guru 1.0, but it fails with 'assert failed: getprop("ro.product.device")=="crespo" || getprop("ro.build.product") == "crespo"' and installation aborts. I guess this isn't surprising, since my values are "crespo4g". What I don't know is if this is overly restrictive and crespo4g *should* also work, and if so, how I would go about changing the checks in the kernel zip. Maybe I should just try to flash the .img using fastboot on my PC or flash_image in my phone's terminal.

I also tried the four Air Kernel Weekly r350 kernels. While they flash without error, there are problems. JBN_BlueColor_NHB_CM and JBN_VDColor_NHB_CM booted, but failed to save screenshots. JBN_BlueColor_CM and JBN_VDColor_CM got stuck in a bootloop at "Android is upgrading... Starting Apps". When flashing the kernels I noticed a message that they were writing to /system, so I tried restoring a nandroid of /system, and that worked for JBN_VDColor_CM (which also couldn't save a screenshot). However, after flashing JBN_BlueColor_CM, /system couldn't be mounted. A reformat and nandroid restore of /system didn't resolve the problem, so I gave up. Even the Air kernels that worked didn't seem to leave much usable memory, so I'm not planning to revisit them and figure out what's wrong. I still have four working kernels to try with OmniRom 4.4.4.

There are still a few aosp-based kernels that require an extra step or two, and I've probably missed a few easily-flashed kernels that are worth a try. I've seen new 4.4.x rom releases for Crespo (like cm11 m9), but I've not gotten far enough to figure out how to extract a flashable kernel..

It's only been 24 hours, so I've obviously not had much of a chance to see how these work for everyday use. That comes next.

Sorry this is so long, I wanted to include enough detail for anyone who wanted to address the problems I've seen, for anyone else who wanted to try other kernels with this rom, and for my own future reference.
Use my guide in flashing boot.IMG and you can flash guru/cm/Slim's kernels without the device error..

Sent from my Nexus S using XDA Premium 4 mobile app
OnePlus ONE
NEVER SETTLE
rom: Slim Saber ( full f2fs )
kernel: AK ( v.32 b12 )
recovery: TWRP (2.7.1.1)
---------------------------------------------------------------------------
i9023 Nexus S
CyanAOSP KitKat (4.4.x) [port]
The War Against Obscurity
(ENTER AT YOUR OWN RISK)

Follow this link to see how your rom compares!!

----------------------------------------------------------------------------

Click "thanks" for developers and anyone that helps you!!
 
mathuaerknedam
Old
#142  
mathuaerknedam's Avatar
Junior Member
Thanks Meter 3
Posts: 25
Join Date: Apr 2014
Quote:
Originally Posted by Setting.Out View Post
Use my guide in flashing boot.IMG and you can flash guru/cm/Slim's kernels without the device error..
Yup. That's where I learned about the option to use flash_image in a terminal. Those kernels will be in the next wave.
 
the1dynasty
Old
#143  
the1dynasty's Avatar
Recognized Themer
Thanks Meter 3,048
Posts: 4,230
Join Date: Dec 2011

 
DONATE TO ME
Quote:
Originally Posted by rsriram22 View Post
I have experienced the 'long boot time' with the omni logo showing up but not doing anything happen. tried clean install, formatted data system partitions/ factory reset nothing worked.

Finally, I went into fastboot and flashed the boot.img manually and the system booted up in matter of seconds. (The boot.img was extracted from the ROM's zip posted in OP).

After the phone booted up fine, I went back to TWRP 2.7.1.0 and flashed gapps-minimal and the reboot was a breeze too (matter of seconds).

I am coming from stock 4.1.2.

Thought this would help someone stuck at boot logo (omni).

and, thanks OP. its a day old that i am on the july 1 build and things seem to work okay so far!
parents came over and i had time to try this and THIS method worked perfectly!!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes