Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,683 Members 51,404 Now Online
XDA Developers Android and Mobile Development Forum

[ROM] [NS4G] CyanogenMod 9 v4.0.4 - v4.0

Tip us?
 
eltrutgnik
Old
#1821  
Senior Member
Thanks Meter 7
Posts: 179
Join Date: Jun 2010
Location: CA
for those that are curious for a changlog:

http://cm-nightlies.appspot.com/?device=crespo4g
 
Nick N
Old
#1822  
Nick N's Avatar
Senior Member
Thanks Meter 164
Posts: 803
Join Date: Sep 2009
Location: Columbus, Ohio
At least on my 04/22/12 nightly you can toggle it by going to Settings > Advanced > Backlight Notifications
Current: AT&T LG Optimus G E970 with CarbonROM 4.4.4 on T-Mobile

Tablets: Nook Color, HTC Flyer, Dell Venue 8 (Android) Android PC Stick: J22 (RK3188) 4.4.2

Retired: HTC Touch/Pro/Pro 2/G1/Samsung Moment/Evo 4G/Nexus S 4G/iPhone 4/Lumia 521 WP 8.1
 
jmilch
Old
(Last edited by jmilch; 27th April 2012 at 07:23 AM.)
#1823  
Junior Member
Thanks Meter 0
Posts: 22
Join Date: Dec 2008
I tried both the nightly 425 and 424, and got the same error..

"assert failed: getprop("ro.product.device") == "crespo4g"

Status 7
Aborted

Suggestions?

**fixed it**

Issue was because I didnt use ROM manager. I installed CWM directly via the command prompt. So each time the phone reset, it went back to the stock recovery image...

Installed rom manager, it worked fine after.
 
wickid_d
Old
(Last edited by wickid_d; 27th April 2012 at 09:36 AM.)
#1824  
Senior Member
Thanks Meter 27
Posts: 169
Join Date: Jan 2011
Location: Somewhere..

 
DONATE TO ME
Quote:
Originally Posted by devlogic View Post
I think you mean Mac OS X, not iOS (the latter being the one for phones, pods, and pads). Mac OS X is built on top of a Unix derivative that's definitely not Linux. Specifically, it's based on (or rather, is/was originally) OPENSTEP, which was made by NeXt and based on FreeBSD/NetBSD, which are in turn based on BSD Unix. See the "Unix" and "OS X" articles on Wikipedia for the full story.

In terms of needing to make modifications to the OS in order to successfully talk to a Nexus S 4G over USB, I haven't needed to on my MacBook. Connecting the USB results in device detection, no matter what mode my handset has been in (note: I haven't tried "firmware restore" mode, but fastboot/bootloader, CWM recovery, and plain old "on" all work fine). In the past, I HAVE had to add my nookColor to the Android SDK's ~/.android/adb_usb.ini, but I've definitely never had to add my Nexus S to any configuration files at all. I think touchfan is right in trying to flash something else, then flashing back to CM9. Alternately, I might flash the stock image ( https://developers.google.com/android/nexus/images ) to reset EVERYTHING, then start over with a fresh fastboot erase recovery and fastboot flash recovery recovery-clockwork-touch-5.8.0.2-crespo4g.img (or other recovery of choice).
ios, Mac os x.. Same crap, different name.. But yeah, that was what I meant.. As a Linux user of 19 years.. (and originally didn't use it for good (Lord Nikon, and the original g3 ring a bell from the late 90s?), but the reason I'm EXTREMELY familiar with the inner workings of android).. Basically, since it first hit the net.. I can assure you the wiki is bad info.. It's built on Debian, which, is built on bsd Unix (that part is right), because I've hacked a Mac os x system to recover a user for a client one time when they forgot their password (NOT an easy task, mind you), and it takes Debian (or bsd Unix) ONLY commands, to do it.. Please bare in mind, wiki is user-submitted, so the information presented is not always accurate..

However, back ot, I think you've basically answered your own question at this point.. lol all Linux, especially back in the early days, is ALL trial and error, with some luck and programming knowledge, soooo yeah, it sounds like you've pretty much got it figured out..
-----
Sent from my phone
using my finger... ;)
-----
=================================================
(If I've helped you in any way, please feel free to tip me by clicking
<-- that button over there, or in the options on your phone, or thanks are
always free )
 
-----
TF201: Rockin the OFFICIAL CM11 4.4.4 nightly w/CMGA 4.4.3, Geass kernel & recovery, F2FS..
oh yeah.. and ART booted.. but lots of FC's with GApps..
Wanna know how? It's pretty easy.. write-up coming soon.. stay tuned..
 
HipToday
Old
#1825  
Junior Member
Thanks Meter 0
Posts: 10
Join Date: Jul 2011
Default Stop vibrating!

I'm running the 20120424 nightly and whenever I select a text field (e.g. typing a text message, composing an email) my phone vibrates. I can turn this off by going to Settings -> Sound -> (uncheck) Vibrate and ring, but that turns off vibrate when I get notifications/phone calls. What's the deal? Is that how it's supposed to work, did I change some other setting somewhere that I'm missing, or is this a bug?

Note, this is different than the haptic feedback that occurs when you're typing on the keyboard, this is a solid "vrrbbbth vrrbbbth" when I tap a text field.
 
tommy0823
Old
#1826  
tommy0823's Avatar
Senior Member
Thanks Meter 423
Posts: 757
Join Date: Oct 2011
Location: joliet
New nightly is up. 4/27


Sent from my Nexus S 4G using xda premium
 
stivelio
Old
#1827  
Senior Member
Thanks Meter 5
Posts: 150
Join Date: Jul 2010
Anything exciting in the new nightly?

Sent from my Nexus S 4G using xda premium
 
Evo_Shift
Old
(Last edited by Evo_Shift; 28th April 2012 at 03:18 AM.)
#1828  
Evo_Shift's Avatar
Senior Member
Thanks Meter 350
Posts: 1,838
Join Date: Jan 2011
Quote:
Originally Posted by stivelio View Post
Anything exciting in the new nightly?

Sent from my Nexus S 4G using xda premium
I would say no. The changelog looks like all behind the scenes stuff. No lock screen customization, flashlight power control button or anything cool like that yet.

http://cm-nightlies.appspot.com/?device=crespo4g
 
jmilch
Old
(Last edited by jmilch; 28th April 2012 at 06:43 PM.)
#1829  
Junior Member
Thanks Meter 0
Posts: 22
Join Date: Dec 2008
Anyone else having a issue with hotspot or opengarden tethering?

I get a "wifi interface" failed error message, along with a few others...

Wifi works otherwise, I did do the kernel fix since I am using a custom kernel. But Tether is not working for me.... and thats half the reason I rooted. Any suggestions?


***Im running the 425 nightly***
 
jmilch
Old
#1830  
Junior Member
Thanks Meter 0
Posts: 22
Join Date: Dec 2008
Quote:
Originally Posted by wctom View Post
I can't get wifi tether to work on the latest cyanogen nightlies from the past week (stock kernel). The hotspot does not show up on other computers.

It works fine with older builds. Anyone else encountering the same problem?
I am going to guess it has something to do with that wifi issue that had to be fixed, moving the file from one folder to another....

Because I can't get it to work either...

Tags
crespo4g ics
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes