Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,772,395 Members 46,617 Now Online
XDA Developers Android and Mobile Development Forum

Getting Nexus S to mount on Linux

Tip us?
 
tycruickshank
Old
#1  
Senior Member - OP
Thanks Meter 39
Posts: 216
Join Date: Dec 2011
Location: Irvine
Default Getting Nexus S to mount on Linux

I just recently installed Arch Linux with KDE as the GUI and I can't for the life of me figure out how to mount my Nexus S. It doesn't show up in /media so I don't know how on earth I can mount it. I've tried in CWM with mount USB and still nothing shows up anywhere on my system. Prior to Arch I was running OS X (10.7) and it was mounting fine. Obviously very different OS and Arch is a lot more complicated to use. I've spent several hours trying to figure out how to mount it but I can't find anything that solves it. Maybe anybody out there using linux could give me a hand?
Rasbean Jelly + Trinity
www.exileskimboards.com
www.skimcity.com

 
Harbb
Old
#2  
Harbb's Avatar
Senior Member
Thanks Meter 469
Posts: 1,108
Join Date: Dec 2011
Location: Sydney
Arch is best Good choice.

Easiest way is to mount it manually. First you'll have to find out which device it is. Plenty of ways to do this, using "fdisk -l" in terminal, gparted, etc. It will be something like "/dev/sdc1". Once you know this, you need to create a folder to mount it. Something like:
mkdir /media/nexus

Now, you need to mount it (after you've chosen to mount on the phone). To do this:
mount -t auto /dev/sdc1 /media/nexus

auto is the file system, you can type fat32 also but it can figure it out. Then the disk location, then where to mount.

You may need root permissions or changes to the sudoers file to do these. Type "man mount" or "man command" for just about every commands manual. I'm on the phone so I can't write up anything much better than that.

Also, the arch Linux wiki is an invaluable resource, make the most of it.
Device: Galaxy Nexus i9250
Previously: Nexus S i9023
The Following 3 Users Say Thank You to Harbb For This Useful Post: [ Click to Expand ]
 
tycruickshank
Old
#3  
Senior Member - OP
Thanks Meter 39
Posts: 216
Join Date: Dec 2011
Location: Irvine
Quote:
Originally Posted by Harbb View Post
Arch is best Good choice.

Easiest way is to mount it manually. First you'll have to find out which device it is. Plenty of ways to do this, using "fdisk -l" in terminal, gparted, etc. It will be something like "/dev/sdc1". Once you know this, you need to create a folder to mount it. Something like:
mkdir /media/nexus

Now, you need to mount it (after you've chosen to mount on the phone). To do this:
mount -t auto /dev/sdc1 /media/nexus

auto is the file system, you can type fat32 also but it can figure it out. Then the disk location, then where to mount.

You may need root permissions or changes to the sudoers file to do these. Type "man mount" or "man command" for just about every commands manual. I'm on the phone so I can't write up anything much better than that.

Also, the arch Linux wiki is an invaluable resource, make the most of it.
Thanks very much for your help. I'll work on this later tonight since I have a lot of school work I need to get done now. Oh yeah you say to mount the device on the computer after pressing mount on the phone but that dialog never actually shows up when I plug the phone in. The phone doesn't recognize it's being plugged into a computer it just shows that it's charging. The arch wiki is definitely a great place for all things arch. Best documentation for any operating system I think I've ever seen.
Rasbean Jelly + Trinity
www.exileskimboards.com
www.skimcity.com

 
Harbb
Old
#4  
Harbb's Avatar
Senior Member
Thanks Meter 469
Posts: 1,108
Join Date: Dec 2011
Location: Sydney
Try in recovery first if it doesn't show up in Android. If it still doesn't show up I'll try to break my arch and fix it, whether its in android or cwm.
Device: Galaxy Nexus i9250
Previously: Nexus S i9023
The Following User Says Thank You to Harbb For This Useful Post: [ Click to Expand ]
 
Si_NZ
Old
#5  
Senior Member
Thanks Meter 32
Posts: 242
Join Date: Jan 2011
Location: Auckland
Quote:
Originally Posted by tycruickshank View Post
Thanks very much for your help. I'll work on this later tonight since I have a lot of school work I need to get done now. Oh yeah you say to mount the device on the computer after pressing mount on the phone but that dialog never actually shows up when I plug the phone in. The phone doesn't recognize it's being plugged into a computer it just shows that it's charging. The arch wiki is definitely a great place for all things arch. Best documentation for any operating system I think I've ever seen.
I've experienced this before as well. It turned out that I had a dodgy cable that's just not compatible with my NS for some reason.

If you want a pop on your KDE desktop when you enable UMS mode on your phone, make sure you udev is added to the daemon list in /etc/rc.conf. Then, you can either reboot or do /etc/rc.d/udev start and restart KDE again.
The Following User Says Thank You to Si_NZ For This Useful Post: [ Click to Expand ]
 
tycruickshank
Old
#6  
Senior Member - OP
Thanks Meter 39
Posts: 216
Join Date: Dec 2011
Location: Irvine
I've tried everything that you guys have said and still no luck. Its not showing up anywhere. Not in fdisk -l, I tried lsusb, looked in /dev/disk and it wasn't there. Nothing was pointing to a device being connected. I checked the everything.log file as well. Last photo is the everything.log and of course these were all taken with my phone connected to my computer. I tried multiple different USB cables too.

Sent from my Nexus S using Tapatalk 2
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1335249730127.jpg
Views:	70
Size:	197.8 KB
ID:	1021917   Click image for larger version

Name:	uploadfromtaptalk1335249743020.jpg
Views:	56
Size:	66.8 KB
ID:	1021918   Click image for larger version

Name:	uploadfromtaptalk1335249758086.jpg
Views:	53
Size:	220.3 KB
ID:	1021919   Click image for larger version

Name:	uploadfromtaptalk1335249777477.jpg
Views:	54
Size:	214.5 KB
ID:	1021922  
Rasbean Jelly + Trinity
www.exileskimboards.com
www.skimcity.com

 
shailentj
Old
#7  
Junior Member
Thanks Meter 3
Posts: 17
Join Date: Mar 2011
Location: Bremen

 
DONATE TO ME
Just curious, with the phone on, and screen unlocked, what do you get with:
adb devices
?
 
samsyr
Old
#8  
Member
Thanks Meter 11
Posts: 56
Join Date: Feb 2012
Sorry but try to check it with other OS to be sure that your USB host is good .

Sent from my Nexus S
 
lithid-cm
Old
#9  
lithid-cm's Avatar
Recognized Developer
Thanks Meter 2963
Posts: 3,177
Join Date: Jul 2010
Location: Cleveland
Unplug the USB. Then plug it back in then immediately run lsusb. If you dont see the device should be /dev/sdb1 should be the device according to your current fstab.

If it does not show in /dev/ or lsusb you have a bad cable.
Sent from my Nexus S 4G using xda premium

Quote:
Choosy moms choose JIF, the others JFIO
Twitter | Google Plus | Scripts | Github | AOSCompiler

The Following User Says Thank You to lithid-cm For This Useful Post: [ Click to Expand ]
 
tycruickshank
Old
#10  
Senior Member - OP
Thanks Meter 39
Posts: 216
Join Date: Dec 2011
Location: Irvine
Well this morning it decided to work. I had turned my computer off last night and I tried it this morning with the same cable and it decided to work. I hope it's not going to be intermittent but seems to be working for now. Thanks everybody for all the help!
Rasbean Jelly + Trinity
www.exileskimboards.com
www.skimcity.com


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes