Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Anyone else having issues with buttons?

OP GrandMstrBud

20th December 2010, 05:01 PM   |  #1  
OP Senior Member
Thanks Meter: 58
 
1,042 posts
Join Date:Joined: Jan 2007
I bought the NS last week on Thursday and the back button seems to stick a lot and I have to press a lot harder. The other 3 buttons work perfect so I'm just curious if anyone else is having similar issues. I'm guessing I'll have to test it back because it's quite annoying having to press it 3-4 times just to get it to work.
20th December 2010, 06:53 PM   |  #2  
raqball's Avatar
Senior Member
Flag Sunny So. Cal...
Thanks Meter: 332
 
796 posts
Join Date:Joined: Jun 2010
More
I had to exchange mine yesterday because the back button would disappear and become completely unresponsive...
20th December 2010, 07:07 PM   |  #3  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Dec 2010
I also exchanged one that had this issue.
20th December 2010, 07:24 PM   |  #4  
Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Aug 2007
The search button and home button did not work for me when I first turned it on. They worked after I restarted it.
20th December 2010, 07:28 PM   |  #5  
krohnjw's Avatar
Recognized Developer
Flag Plainfield
Thanks Meter: 531
 
1,980 posts
Join Date:Joined: Jul 2007
More
No button problems here

Sent from my Nexus S using XDA App
20th December 2010, 07:35 PM   |  #6  
rashad1's Avatar
Senior Member
Flag New York
Thanks Meter: 74
 
762 posts
Join Date:Joined: Jun 2010
More
My buttons haven't had any problems thus far
20th December 2010, 07:50 PM   |  #7  
Senior Member
Thanks Meter: 54
 
885 posts
Join Date:Joined: Mar 2009
Make sure you have that factory screen protector off. I've had it happed with my Vibrant, but once I took it off, everything was actually working fine.
Last edited by DKYang; 20th December 2010 at 07:56 PM.
20th December 2010, 07:54 PM   |  #8  
OP Senior Member
Thanks Meter: 58
 
1,042 posts
Join Date:Joined: Jan 2007
Glad to see I'm not the only one but it sucks that I have to exchange it though and re root it all over again.
20th December 2010, 11:52 PM   |  #9  
Darrien13's Avatar
Senior Member
Thanks Meter: 20
 
1,181 posts
Join Date:Joined: Jan 2009
More
the back button sucks in general Ive gone through 2 but I still have the plastic maybe thats my problem
20th December 2010, 11:54 PM   |  #10  
Androidfreakz's Avatar
Senior Member
Thanks Meter: 40
 
320 posts
Join Date:Joined: Oct 2010
Ive also had that issue best buy replaced it for me. This units back button works great.

Sent from my Nexus S using XDA App

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes