Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

CleanSlate Brings Fingerprint Scanner Mod to HTC One M9+

Work of XDA Recognized Developer tbalden, CleanSlate custom kernel for the HTC … more

Sunday Debate: Which Factors Caused HTC’s Woes?

Join us in a fun Sunday Debate on HTC’s situation. Come with your … more

HTC’s New Ad Campaign And What It Really Means

HTC has just released three new blind test adverts comparing app loading … more

[Q] No data connection on my Nexus S

4 posts
Thanks Meter: 0
By infinite_ammo, Junior Member on 23rd February 2014, 10:09 AM
Post Reply Subscribe to Thread Email Thread
So one day, my Nexus S randomly decided not to have a data connection with my carrier (Wind Mobile) anymore.
Wifi works, mobile data does not.

Steps I did to try and fix this:
1) make sure APN address is correct, which it is.
2) turn airplane mode on and off
3) toggle carrier connection on and off
4) factory wipe phone and reinstall ROM (slimkat)
5) factory wipe phone and install a different ROM (AOSP)
6) flash new radio (KB3 and KB1)

Other things I tried:
1) tried my SIM card with another phone (Blackberry Curve), data connection seems to work fine on that phone.
2) Called Wind Mobile and asked them to reset their towers to my phone... all they did was remove the Blackberry security thingy
that I had with them when I was still using a Blackberry. Rebooted my Nexus S, tried again... still no data.

So... I'm at my wit's end, and I have no clue how to fix this. Any ideas? I've found a couple similar threads for this problem... non of which had a solution to mine.
23rd February 2014, 04:37 PM |#2  
OP Junior Member
Thanks Meter: 0
I remembered I made a backup nandroid a little while ago... and I restored it.
Voila, everything works again. But as soon as I tried reflashing to my preferred ROM (Slimkat), the problems started up again.
I also forgot to add that before I started encountering problems, my phone froze and I had reset by doing a battery pull because it wouldn't respond to any key presses. I'm guessing it corrupted something, though I'm not sure what. I've diagnosed that this is not a hardware issue, and that it's purely software... I'm not sure why the problem comes back when I reflash to another ROM. I'll keep you guys posted.
25th February 2014, 02:52 AM |#3  
OP Junior Member
Thanks Meter: 0
One other thing worth noting is that when I have Slimkat installed, it doesn't seem to read off my SIM card properly.
The APN doesn't get named "Wind DATA" like it usually does when I install a different ROM on there; it just gets named "Internet".
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes