Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

YU Yureka: Indian Handset with CyanogenMod

Thesoap opera involving Cyanogen Inc., OnePlus, and Micromax is one of the most talked about … more

Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Fastboot and locking problems

OP mikeydubbs

24th April 2012, 05:12 AM   |  #11  
shahravi94's Avatar
Senior Member
Thanks Meter: 23
 
194 posts
Join Date:Joined: Sep 2011
More
i sent my phone in for a broken power button as well. I couldn't even get into the bootloader to relock it so i sent it with an unlocked bootloader. they still fixed it.
24th April 2012, 03:57 PM   |  #12  
OP Member
Flag London, ON
Thanks Meter: 6
 
67 posts
Join Date:Joined: Dec 2011
Donate to Me
More
Quote:
Originally Posted by shahravi94

i sent my phone in for a broken power button as well. I couldn't even get into the bootloader to relock it so i sent it with an unlocked bootloader. they still fixed it.


so do you think as long as its not rooted they wont care?
24th April 2012, 08:04 PM   |  #13  
shahravi94's Avatar
Senior Member
Thanks Meter: 23
 
194 posts
Join Date:Joined: Sep 2011
More
yup! i flashed a stock image so it was unrooted and sent it in. they fixed it up for me
30th July 2012, 03:04 PM   |  #14  
Junior Member
Thanks Meter: 3
 
4 posts
Join Date:Joined: Sep 2010
If you are using Linux you might need su permissions!

Try:

sudo fastboot oem lock
5th June 2014, 07:22 PM   |  #15  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by mikeydubbs

hey so i need to send my nexus s in for repair and i have stock rom and recovery, but every time i try fastboot oem lock it just sits at "waiting for device"
ADB works fine.
I tried alternative drivers

What can i do to re lock my phone?


Hi, I know this thread is old but I was having the same problem relocking my nexus 4 after installing stock Android 4.4.3 KitKat.
I'm using Nexus Root Toolkit, I don't know what tools you're using to lock your nexus S boblem ut this very easy to use it downloads the drivers and what ever you need to lock, unlock or flash stock and custom roms for any Nexus device.

So my problem was that I would launch OEM Lock on Nexus Root Toolkit and it would detect the device, reboot in Fastboot mode and it would proceed just fine but after saying "Launching TWRP.... something" it would reboot the phone and say to me "Waiting for device" untill it would time out.

I found out that when the program(NEXUS ROOT TOOLKIT) asked me to download a TWRP IMG files, I said no everytime because I didn't think I'd need it. So after trying 5 times, I allowed it to download it and i retryed to OEM Lock it and MAGIC!
Somewhere in the process of Locking the rom it is going to need the TWRP File so allowing the program to download it solved it for me.

I don't know if this will help you or if you still have the same phone, but if you do have use Nexus Root Toolkit and download all it asks and you'll be fine.

Good Luck.
2nd July 2014, 04:03 AM   |  #16  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2014
Question "waiting for device" forever when "fastboot oem unlock:
Quote:
Originally Posted by mikeydubbs

hey so i need to send my nexus s in for repair and i have stock rom and recovery, but every time i try fastboot oem lock it just sits at "waiting for device"
ADB works fine.
I tried alternative drivers

What can i do to re lock my phone?

I have the same exact problem.

ADB works fine when the phone is up & running, so I am suspecting a driver compatibility problem when the phone is in "FASTBOOT MODE".

I tried to install the "Universal Naked Driver 0.73 (Compatible with Nexus 5, 4, 7, 10 and S)" but Windows 7 64-bit refuses to pick it up. I use the Device Manager method which shows (when the phone is in "FASTBOOT MODE"):

Code:
 "Other Devices
     > Android 1.0"
When the phone is up & running, Device Manager shows it as:

Code:
"Android USB Devices 
 > SAMSUNG Android Composite ADB Interface"
Any idea how to proceed from here?

-----

Update: After a day went by, I searched Google some more and found a thread that describes exactly my problem:

http://forum.xda-developers.com/nexu...roid-1-t878579

Which led me to:

http://forum.xda-developers.com/nexu...28#post9861928

Which led me to:

http://pdanet.co/a/

I am rushing to try this now...

-------

Success!

Quote:

~> fastboot oem unlock
...
OKAY [ 18.734s]
finished. total time: 18.734s

Last edited by positiveplus; 3rd July 2014 at 05:08 AM. Reason: Discovery!
14th October 2014, 08:44 PM   |  #17  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2014
Quote:
Originally Posted by nunojpg

If you are using Linux you might need su permissions!

Try:

sudo fastboot oem lock

It helped. Thanks!

Post Reply Subscribe to Thread

Tags
adb, fastboot, lock, nexus
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes