FORUMS

HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

How to Disable ICS bugfix/bugreport?

597 posts
Thanks Meter: 151
 
By IIIV, Senior Member on 17th January 2012, 11:30 PM
Post Reply Subscribe to Thread Email Thread
Hi, everyone. I always accidentally press my NS' power + volume up buttons, which activates the bugfix/bugreport email window.

Is there any way to safely disable this feature?

Thanks in advance.
 
 
18th January 2012, 06:26 AM |#2  
flodb113's Avatar
Senior Member
Thanks Meter: 113
 
More
Sorry to ask, but what? You mean you press them when powering up the phone? If not, could you post a screenshot?

Transmitted from somewhere in space... from my Nexus S... and Tapatalk.
18th January 2012, 08:57 PM |#3  
IIIV's Avatar
OP Senior Member
Flag Hawaii
Thanks Meter: 151
 
More
Quote:
Originally Posted by flodb113

Sorry to ask, but what? You mean you press them when powering up the phone? If not, could you post a screenshot?

Transmitted from somewhere in space... from my Nexus S... and Tapatalk.

Yes, I accidentally press them when powering on or off my NS. Try holding the power and volume up buttons. Your NS will vibrate and bring up your default email app and compose a bugfix/bugreport email for you.
22nd January 2012, 06:58 AM |#4  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by IIIV

Yes, I accidentally press them when powering on or off my NS. Try holding the power and volume up buttons. Your NS will vibrate and bring up your default email app and compose a bugfix/bugreport email for you.

Exactly what I am searching online for. I always get the sharing options appear out of nowhere and only realise that it is trying to send a bug report.

After some extended searching, I finally knew how it was activated. By pressing Volume up + Volume down + power button, you will feel a vibration after a second or so, that's when the bug reporting initiated.

http://code.google.com/p/ics-crespo/...094f6587b4b675

However, I have no idea how to disable it. It become very annoying especially when waking up the phone from sleep and you find that your device is lagging because of the bug report generation.

Any help?
22nd January 2012, 02:48 PM |#5  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by ghost_301

Exactly what I am searching online for. I always get the sharing options appear out of nowhere and only realise that it is trying to send a bug report.

After some extended searching, I finally knew how it was activated. By pressing Volume up + Volume down + power button, you will feel a vibration after a second or so, that's when the bug reporting initiated.

http://code.google.com/p/ics-crespo/...094f6587b4b675

However, I have no idea how to disable it. It become very annoying especially when waking up the phone from sleep and you find that your device is lagging because of the bug report generation.

Any help?

Turn off USB debugging.
The Following User Says Thank You to Uni7 For This Useful Post: [ View ]
22nd January 2012, 05:24 PM |#6  
IIIV's Avatar
OP Senior Member
Flag Hawaii
Thanks Meter: 151
 
More
The solution that I've found, without turning off USB debugging, is renaming the file "bugmailer.sh" (to something like "bugmailer.sh-backup"), which is found in /system/bin.

P.S. For me, I need USB debugging turned on, because it is required by Titanium Backup, which I often use. If you don't need USB debugging turned on all the time, you could just turn it off, like Uni7 posted, and it'll also solve this issue.
The Following User Says Thank You to IIIV For This Useful Post: [ View ]
26th January 2012, 01:26 PM |#7  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by IIIV

The solution that I've found, without turning off USB debugging, is renaming the file "bugmailer.sh" (to something like "bugmailer.sh-backup"), which is found in /system/bin.

P.S. For me, I need USB debugging turned on, because it is required by Titanium Backup, which I often use. If you don't need USB debugging turned on all the time, you could just turn it off, like Uni7 posted, and it'll also solve this issue.

You shouldn't need USB debugging for TB on any new rom. From official FAQ:

Quote:

40. Why does Titanium Backup demand that the Android Debugging Bridge (ADB) be enabled? I don't develop on my phone and don't want this.

The only reason is that on some ROMs, earlier versions of Superuser (the app that grants root privileges) didn't work properly if ADB (USB debugging) was disabled. This is why I added the warning at startup.
Nowadays, on most ROMs you can leave USB debugging disabled in your phone settings and also disable that warning in Titanium Backup. The option is: MENU -> Preferences -> "Warn if no USB debug".

28th January 2012, 02:56 PM |#8  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Uni7

You shouldn't need USB debugging for TB on any new rom. From official FAQ:

Thanks for the info, it works! Never know it's the USB Debugging option, guess I never explore deep enough. :P

Thanks again!
18th March 2012, 10:22 AM |#9  
Junior Member
Flag Fiumicino - FC
Thanks Meter: 0
 
Donate to Me
More
Quote:
Originally Posted by Uni7

Turn off USB debugging.

[CM9 nightly] unluckly this doesn't help
18th March 2012, 10:25 AM |#10  
DarkhShadow's Avatar
Senior Member
Flag Essex
Thanks Meter: 278
 
More
Quote:
Originally Posted by IIIV

The solution that I've found, without turning off USB debugging, is renaming the file "bugmailer.sh" (to something like "bugmailer.sh-backup"), which is found in /system/bin.

P.S. For me, I need USB debugging turned on, because it is required by Titanium Backup, which I often use. If you don't need USB debugging turned on all the time, you could just turn it off, like Uni7 posted, and it'll also solve this issue.







Quote:
Originally Posted by mcalamelli

[CM9 nightly] unluckly this doesn't help



Sent from my ice cream powered Nexus S
30th April 2012, 04:48 PM |#11  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by mcalamelli

[CM9 nightly] unluckly this doesn't help

have you solved this problem ?

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes