Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[SOLVED][Q] Help phone won't pass Google after being soaked in water!

OP khimois

6th February 2014, 01:21 AM   |  #1  
khimois's Avatar
OP Senior Member
Thanks Meter: 42
 
229 posts
Join Date:Joined: Jun 2013
More
Umh...

So, my phone got soaked in water for I think 10mins or more? I'm not really sure but when I found out, we immediately removed the battery then disassembled it and let it dry for 2 hours then since I'm at work, I reassemble it and went home. My travel time is about 1 1/2 hour then I take out my cellphone and let it dry for about 2 hours.

Okay, after that 2 hours, I tried opening again my phone, I attached the battery and TURNED it ON by pressing the power button, then it opens but it won't pass the Google logo... I remove the battery and attached it again then I tried to go to recovery mode, I got in bootloader but when I tried to boot again in recovery, it still won't pass the Google logo, I removed the battery again and tried to boot it again but when I attached the battery, it AUTOMATICALLY TURNED ON then I detached the battery again and dry it again overnight until now...

So my question is, do you think my phone will still work? Or perphaps I won't be able to use it again? I'm worried since it's my only android phone I have.

Please enlighten me! Thank you.

EDIT:

SOLVED!!!


Okay, my phone is working again, thanks to my father who clean the board using thinner and it's now smooth as it is before, well, as of now and I'm still observing if there's damage left...

Thanks for everyone who helped. LOL
Last edited by khimois; 11th February 2014 at 01:27 AM.
6th February 2014, 10:59 AM   |  #2  
Senior Member
Flag Mumbai
Thanks Meter: 135
 
408 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by khimois

Umh...

So, my phone got soaked in water for I think about 10mins? I'm not really sure but when I found out, we immediately removed the battery then disassembled it and let it dry for 2 hours then since I'm at work, I reassemble it and went home. My travel time is about 1 1/2 hour then I take out my cellphone and let it dry for about 2 hours.

Okay, after that 2 hours, I tried opening again my phone, I attached the battery and TURNED it ON by pressing the power button, then it opens but it won't pass the Google logo... I remove the battery and attached it again then I tried to go to recovery mode, I got in bootloader but when I tried to boot again in recovery, it still won't pass the Google logo, I removed the battery again and tried to boot it again but when I attached the battery, it AUTOMATICALLY TURNED ON then I detached the battery again and dry it again overnight until now...

So my question is, do you think my phone will still work? Or perphaps I won't be able to use it again? I'm worried since it's my only android phone I have.

Please enlighten me! Thank you.

Is your bootloader unlocked?
If yes, then install a custom recovery and backup all the stuff you have by mounting SD card.
Then, flash the factory image to make your phone as good as new.
6th February 2014, 11:28 AM   |  #3  
khimois's Avatar
OP Senior Member
Thanks Meter: 42
 
229 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by smit.sanghavi

Is your bootloader unlocked?
If yes, then install a custom recovery and backup all the stuff you have by mounting SD card.
Then, flash the factory image to make your phone as good as new.

Yes, it's unlocked, I've flash quite frequently... and I have CWM 6.0.4.3 already installed, that's why I've wondering why my phone won't boot in recovery mode...
6th February 2014, 12:38 PM   |  #4  
Senior Member
Flag Mumbai
Thanks Meter: 135
 
408 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by khimois

Yes, it's unlocked, I've flash quite frequently... and I have CWM 6.0.4.3 already installed, that's why I've wondering why my phone won't boot in recovery mode...

Just a hunch, recovery file may be missing or corrupt.

Flash CWM again from bootloader and try to go in recovery.
7th February 2014, 01:12 AM   |  #5  
khimois's Avatar
OP Senior Member
Thanks Meter: 42
 
229 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by smit.sanghavi

Just a hunch, recovery file may be missing or corrupt.

Flash CWM again from bootloader and try to go in recovery.

Okay, will try, I've decided to let it dry for 1 week since when I put the battery it will turn on automatically.


Or can it be hardware problem already?
7th February 2014, 06:56 AM   |  #6  
Senior Member
Flag Mumbai
Thanks Meter: 135
 
408 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by khimois

Okay, will try, I've decided to let it dry for 1 week since when I put the battery it will turn on automatically.


Or can it be hardware problem already?

Not sure... that's why I said to install a recovery to see if the memory is damaged or no..

There is also a home-made method to remove moisture. Soak the phone in a bowl a rice. Tried and tested.
7th February 2014, 07:48 AM   |  #7  
khimois's Avatar
OP Senior Member
Thanks Meter: 42
 
229 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by smit.sanghavi

Not sure... that's why I said to install a recovery to see if the memory is damaged or no..

There is also a home-made method to remove moisture. Soak the phone in a bowl a rice. Tried and tested.

Ok then thanks!

And... yeah, my phone is now soaked in in bowl of rice, will remove after a 3-4 days or more...
11th February 2014, 01:25 AM   |  #8  
khimois's Avatar
OP Senior Member
Thanks Meter: 42
 
229 posts
Join Date:Joined: Jun 2013
More
Updated OP! Solved! Thanks everyone! <3

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes