How to Disable Data Encryption on Nexus 6

In late September, Google decided to step on NSA’s toes and turn on encryption by default in … more

DJI Phantom 2 Vision+ Review – XDA TV

The holidays will be here in no time, so why not start thinking about gifts now? Youll be ahead … more

Mozilla Ditches Google, Makes Yahoo Default Search Engine

Mozilla and Google have had a long-standing relationship of about 10 years. Google … more

Learn More About Linux with Linux Man Pages

Linux is quite a powerful and very configurable operating system. Thanks to some user-friendly … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Type password to decrypt storage?

OP dejrfan

10th September 2012, 05:22 AM   |  #1  
dejrfan's Avatar
OP Junior Member
Thanks Meter: 1
 
5 posts
Join Date:Joined: Apr 2011
I've had my Nexus S for a year now and it's been pretty problem free... When it had Gingerbread it had the odd reboot glitch but since ICS it's been solid. I have the bootloader unlocked and had root. I had tried out a couple of custom ROMs and had gone back to stock ICS in anticipation of JB rolling out in July. I got the OTA push of JB in mid July and after a factory refresh have had no problems with the phone until yesterday.
I was typing a text message and my phone rebooted in my hand. It never did complete booting and left me at a prompt that stated "Type password to decrypt storage" and nothing would make this phone boot! Also, since the JB update I no longer had root and Clockwork Recovery no longer worked because I didn't have root... which I wasn't worried about up until now. I had to tether the phone to my laptop reset Recovery using the SDK tools and then wipe everything and reset the phone and reinstall all my apps. Funny thing is I've not been able to find much about this from any of the forums I read frequently... seems there aren't many who have experienced this.
Just wondering if anyone else has run into it...
The Following User Says Thank You to dejrfan For This Useful Post: [ View ]
10th September 2012, 04:59 PM   |  #2  
Member
Thanks Meter: 14
 
67 posts
Join Date:Joined: Mar 2012
More
it's happend for me too. i had to wipe cache and fixed.
2nd January 2013, 01:57 PM   |  #3  
Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Jun 2009
Unhappy
Same thing happened to my Nexus S. I have no idea how it came into this "type password to decrypt storage" damned state. I'm trying all passwords and PINs I know but none is working! I'm trying to avoid a factory reset.... Isn't there a way to log in and override this thing, something like forgotten password in emails???
Last edited by hajjat; 2nd January 2013 at 02:00 PM.
8th February 2013, 10:15 PM   |  #4  
Member
Thanks Meter: 8
 
68 posts
Join Date:Joined: May 2008
Donate to Me
More
still no solution for this? i've wiped data and cache and still no fix!
11th February 2013, 08:37 PM   |  #5  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2011
More
I'm facing the same issue: woke up this morning to find my phone asking for a password in order to decrypt storage. Very annoying, since I don't have a very recent backup.

Running CM10.1 nightly 0210 with stock CM kernel. I tried reinstalling CM and wiping cache, but that didn't help. I'll see if I can fix it and and will repost here if/how I fixed it.
Last edited by kooske; 11th February 2013 at 09:21 PM.
11th February 2013, 08:52 PM   |  #6  
Senior Member
Flag Toronto
Thanks Meter: 38
 
216 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by gearjunkeez

still no solution for this? i've wiped data and cache and still no fix!

If you can boot into bootloader (fastboot), try to flash Google factory image.

untar (unrar/7-zip) the tar file and flash the update zip within. This should wipe everything including system.

Code:
fastboot -w update image-soju-jzo54k.zip
13th February 2013, 09:12 PM   |  #7  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by kooske

I'll see if I can fix it and and will repost here if/how I fixed it.

It seems that there is no other solution for this other than a wipe data/factory reset. It's the solution offered in a googleGroups discussion as well. (Can't post links yet, not enough posts...)

Luckily after re-installing ROM and gapps all my apps were restored, and I was able to extract all my pictures and some backups on the sdcard using the mount USB option in CWM. So no big data loss for me.

It's a strange issue though, and should've been solved long ago. First occurrence I found was somewhere in February 2012, that's a year ago!
24th February 2013, 03:29 AM   |  #8  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2013
HELP!
I just had the same thing happen to my phone. Can you please dumb down what you just said for me? The only part I care about is how to recover my pictures. I haven't done the factory reset yet as I've been trying every password I can think of and now see that it is a bug and not something I have done. Anyway, I have 3 gigs of pictures of my 18 month old that I will cry if I lose so if you can help me recover them I would really appreciate it. I have tried hooking my phone up to my computer in it's encrypted state and it does not register. Please explain what you did in simplified terms for me as I have no idea what ROM or CWM means. Thanks!

Quote:
Originally Posted by kooske

It seems that there is no other solution for this other than a wipe data/factory reset. It's the solution offered in a googleGroups discussion as well. (Can't post links yet, not enough posts...)

Luckily after re-installing ROM and gapps all my apps were restored, and I was able to extract all my pictures and some backups on the sdcard using the mount USB option in CWM. So no big data loss for me.

It's a strange issue though, and should've been solved long ago. First occurrence I found was somewhere in February 2012, that's a year ago!


Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes