Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,005 Members 49,015 Now Online
XDA Developers Android and Mobile Development Forum

[Q] USB connection issues

Tip us?
 
Fas1h
Old
(Last edited by Fas1h; 3rd June 2014 at 12:55 AM.)
#1  
Senior Member - OP
Thanks Meter 42
Posts: 282
Join Date: Jun 2012
Location: Karachi
Location [Q] USB connection issues

So, I unlocked bootloader, flashed cwm, now I cant copy ROM to the phone, problem is phone DOES connect, the drive shows up, I can open it to see the existing folders inside. But I cant copy/delete anything to it. Its like its on read only permission.
On windows 8.1 I cant find any option in the properties to change permission.
Same with windows 7, no option to change the permissions.
On linux mint there is the option to change permissions, but sadly they wont change.

I have tried connecting both via the ROM itself and the cwm > mounts and storage > mount usb storage. Same result either way.

I have also tried pushing files via ADB, the process never completes.

Well, if it were usb issue, it wont even let me see the current files inside, so i am at a loss now. Thats all I could think of. Tried it on 2 laptops and one pc already.

Any suggestions?
Right now transfering ROM via bluetooth. But its taking mighty long (obviously).


EDIT: Nopes, cant do anything. It wont flash any other recovery now, in fastboot after the 'fastboot flash recovery........" it says "out of memory" if not that, it just hangs and does nothing.
Via terminal emulator it does not recognize flash_image
and cant flash rom unless i update the recovery.
So right now the priority is to update recovery, anybody know of any other terminal emulator command? ROM manager is not recognizing the current cwm recovery. and there was RASHR says done, but when i reboot its still the same old recovery.

Edit:
So I found this:
Quote:
Originally Posted by Theonew View Post
Do:
Code:
fastboot erase recovery
Then reflash recovery.
Any ideas? Will this help with the out of memory issue?
 
Fas1h
Old
(Last edited by Fas1h; 3rd June 2014 at 10:38 AM.)
#2  
Senior Member - OP
Thanks Meter 42
Posts: 282
Join Date: Jun 2012
Location: Karachi
I erased the recovery now I am getting this...

C:\Users\fasih\Desktop\asdsadasdsa\NexusS_files\NS Files>fastboot flash recovery
ttw.img
< waiting for device >
sending 'recovery' (5572 KB)...
FAILED (data transfer failure (Too many links))
finished. total time: 0.251s


First of all thanks to the 68 viewers of this thread I managed to solve it, after 2 lappy's and 1 pc and 3 cables I found that the cables were all faulty, just got a new one and it solved the problem. Thanks for bearing with me guys.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes