Post Reply

Fix: SanDisk 64GB SD Card, All Data Missing

OP Jonas151

17th August 2014, 11:12 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Mar 2011
More
I didn't see this particular fix anywhere else, but it seems to be happening with larger SD cards for many phones, so...

Running: L900 CM11 4.4.4 mid-august nightly w/ stock kernel.

Problem: My SanDisk 64GB SDXC SD card was mounting but showing no data and no absolute file size, with only the option available in tools being the delete all data function (I never tried using it though.)

Kitchen Sink: Tried rebooting, wiping both caches and flashing an older nightly. While a fresh card format seems like the obvious fix, transferring and formatting takes time on such a big card and requires a PC nearby.

The Fix: I booted the phone with the back cover off, and without the SD card inserted. After a full boot to my home screen, I then inserted the offending card and received a notice that it was loading. Saved data was now available with all functionality. After a reboot and battery pull, the card hasn't failed to load since.

I'd be interested in any insight to why this might have worked, it feels like a janky fix at best. A quick search tells you that big SD cards and CM/Android don't always play well.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Sprint Galaxy Note II General by ThreadRank