Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,778 Members 38,061 Now Online
XDA Developers Android and Mobile Development Forum

4.3 Custom ROMs Keep Losing Root

Tip us?
 
veeman961
Old
#21  
Member
Thanks Meter 1
Posts: 39
Join Date: Feb 2013
Location: Naperville
Quote:
Originally Posted by nickf123654 View Post
I have tried flashing root in recovery and then installing super su after the phone boots but it is unable to install the su binary and I get the error from the screenshot in the 2nd post of this thread
I'm not completely sure if this will work, but i had the same problem at some point. I also hv a T-mobile Samsung Galaxy Note 2 and this happened to me awhile back. I was never able to find a solution online for it so I just common sensed my way through it. My phone was having a bunch of glitches.....I don't even know how to explain them.
Root was on and off just like it is for u.
TWRP was acting really weird: when ever i would flash a new rom or wiped data or system, nothing would happen; its as if TWRP was just telling me everything was working, when nothing was working at all!


What I ended up doing was reverting to the stock image. I used Odin to flash the stock image. then i flashed a custom recovery, then i rooted my device. This time there were no problems. If you are gonna try this just make sure to back up all important data. And once again, im not sure if this will work but try it out and lemme know!
The Following User Says Thank You to veeman961 For This Useful Post: [ Click to Expand ]
 
nickf123654
Old
#22  
nickf123654's Avatar
Member - OP
Thanks Meter 3
Posts: 77
Join Date: Aug 2008
Location: Tampa

 
DONATE TO ME
I think I may have figured out what is happening here.... I think the SuperSU app and SU binary are getting messed up when the SU app updates from the market. This would explain why it will sometimes break over night.

I tried flashing SU in recovery a bunch of times and it doesn't restore root but if I re-flash my ROM, I usually get root back. I think the difference is that all the SU components are getting reset to default when I re-flash the ROM but when I flash SU, it is just applying it on top of the existing root/su.

I was checking some settings and I found a work around that seems to restore root without having to re-flash my ROM....

Settings > More > Application Manager > ALL > SuperSU > Uninstall updates

Then, I reboot the phone and root is restored when it comes back up.

I have tested this by updating and uninstalling the updates a few times and I lost root every time I updated and it came back every time I uninstalled the updates and rebooted.

I disabled auto update in the market for SuperSU, so hopefully this issue stops happening. If not, at least I have an easy fix.

Thanks to all for the suggestions & help!
Let me know if this fix helps anyone else!
Current Devices:
Primary Line: Samsung Note 2 (T-Mobile)
Work Line: HTC Inspire 4G (AT&T)
Tabs: Samsung Galaxy 10.1 & iPad 2
Console: Ouya

I'm old school, used to work for T-Mobile back in the day & my first Android was the HTC G1.
 
Double0EK
Old
#23  
Double0EK's Avatar
Senior Member
Thanks Meter 835
Posts: 2,054
Join Date: May 2010
I just built a rom and Im was having issues with SuperSu staying. I normally dont have any issues flashing supersu and having it work but for some reason the only way it worked was to update the app, to 2.01, from the PlayStore and then letting it install the SU Binary by rebooting into recovery.
 
nickf123654
Old
#24  
nickf123654's Avatar
Member - OP
Thanks Meter 3
Posts: 77
Join Date: Aug 2008
Location: Tampa

 
DONATE TO ME
Quote:
Originally Posted by Double0EK View Post
I just built a rom and Im was having issues with SuperSu staying. I normally dont have any issues flashing supersu and having it work but for some reason the only way it worked was to update the app, to 2.01, from the PlayStore and then letting it install the SU Binary by rebooting into recovery.
I think this issue has to do with how the SU updates are applied. It is the only thing I can think of that makes sense. I would have root and then lose it (maybe SU app updated to cause this) then after a while root would come back all by itself (maybe app updated again & fixed/restored access).

This has been going on for about as long as I can remember since I upgraded my Note 2 to 4.3. I'm not sure how often the SU app was updated or if the updates were around the same time root was lost or restored. I don't really have a way to check.

So far, I have not lost root again since uninstalling updates and disabling auto update in the market for SuperSU.
Current Devices:
Primary Line: Samsung Note 2 (T-Mobile)
Work Line: HTC Inspire 4G (AT&T)
Tabs: Samsung Galaxy 10.1 & iPad 2
Console: Ouya

I'm old school, used to work for T-Mobile back in the day & my first Android was the HTC G1.
 
sunglint
Old
#25  
Senior Member
Thanks Meter 27
Posts: 125
Join Date: Feb 2008
Location: Houston
Battery Low Happens on Omnirom too

Running Omnirom, updating at least weekly, this happened most recently last week. I'm using PhilzTouch and keep SuperSU zip on my SD card so I just reboot into recovery and reinstall when it happens.
Possibly related is a weird power-off behavior. Sometimes when I shut down the phone while it's on charge it will shutdown but when it shifts over to the battery charging screen it locks at a grey screen, and will stay like that with the screen on even after it's unplugged, draining the battery and requiring a battery pull.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes