Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

4.4.2 and proximity sensor problem

OP jellyhead

8th July 2014, 04:21 PM   |  #1  
OP Senior Member
Thanks Meter: 46
 
198 posts
Join Date:Joined: Sep 2010
I just updated to SR Remix KitKat and I noticed that my proximity sensor isn't working now. I can't say for sure that it was the update which caused the problem because a week before this I had the screen glass replaced. Now I know this can be a problem when the screen glass is replaced but I wanted to verify that it wasn't caused by the update before I take the phone apart and try to fix it. I'm posting here to see if anyone else has had this problem with this update or ROM. I tried the hidden menu *#0*# and it wasn't functioning. I also checked with CPU-Z and there was no activity at all from the sensor.
9th July 2014, 05:36 PM   |  #2  
devious_z's Avatar
Junior Member
Thanks Meter: 6
 
13 posts
Join Date:Joined: Jul 2014
Phone
Quote:
Originally Posted by jellyhead

I just updated to SR Remix KitKat and I noticed that my proximity sensor isn't working now. I can't say for sure that it was the update which caused the problem because a week before this I had the screen glass replaced. Now I know this can be a problem when the screen glass is replaced but I wanted to verify that it wasn't caused by the update before I take the phone apart and try to fix it. I'm posting here to see if anyone else has had this problem with this update or ROM. I tried the hidden menu *#0*# and it wasn't functioning. I also checked with CPU-Z and there was no activity at all from the sensor.


I also updated my I605 to SR Remix KitKat last night, and can confirm that my prox sensor is working fine (just made a few calls to be sure ).

Looks like you may need to do some tinkering with that glass panel..
12th July 2014, 07:12 AM   |  #3  
OP Senior Member
Thanks Meter: 46
 
198 posts
Join Date:Joined: Sep 2010
Well I found that it was in fact a shoddy glass replacement. Too bad I already gave the eBay guy positive feedback.

What I found when I removed the proximity sensor was that the back side if the glass windows for the front facing camera, proximity sensor and ambient sensor all had glue residue covering them. It took a little bit of rubbing with a Q-tip and Goof-Off to get it clean enough to work. I'm sure glad I paid someone to do the job right so that wouldn't happen *sarcasm* I'll just do the job myself next time.
16th July 2014, 10:48 PM   |  #4  
devious_z's Avatar
Junior Member
Thanks Meter: 6
 
13 posts
Join Date:Joined: Jul 2014
Thumbs up
Quote:
Originally Posted by jellyhead

Well I found that it was in fact a shoddy glass replacement. Too bad I already gave the eBay guy positive feedback.

What I found when I removed the proximity sensor was that the back side if the glass windows for the front facing camera, proximity sensor and ambient sensor all had glue residue covering them. It took a little bit of rubbing with a Q-tip and Goof-Off to get it clean enough to work. I'm sure glad I paid someone to do the job right so that wouldn't happen *sarcasm* I'll just do the job myself next time.

Hehe

Glad you got it working.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes