Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] problem toggling wifi

OP kmasterz

31st July 2014, 08:38 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Dec 2010
Hey guys, I've had this problem ever since android 4.3, had it on 4.4.2, and after trying liquidsmooth's 4.4.4, the problem still exists. Wifi keeps dropping to LTE, and if I try to toggle wifi back on, the toggle switch "hangs" for a moment on the "on" switch while greyed out, and then automatically switches back to the "off" switch. Only after some time passes, sometimes taking several days, does the wifi randomly switch back on. Does anybody else have had to deal with this problem? And how were you able to resolve it? Thanks in advance
1st August 2014, 02:35 PM   |  #2  
lacoursiere18's Avatar
Recognized Themer
Flag LbTs
Thanks Meter: 5,226
 
3,604 posts
Join Date:Joined: Jan 2013
Donate to Me
More
Quote:
Originally Posted by kmasterz

Hey guys, I've had this problem ever since android 4.3, had it on 4.4.2, and after trying liquidsmooth's 4.4.4, the problem still exists. Wifi keeps dropping to LTE, and if I try to toggle wifi back on, the toggle switch "hangs" for a moment on the "on" switch while greyed out, and then automatically switches back to the "off" switch. Only after some time passes, sometimes taking several days, does the wifi randomly switch back on. Does anybody else have had to deal with this problem? And how were you able to resolve it? Thanks in advance

Hmm sounds like a Rom problem. Does anyone else installing Liquid Smooth have that issue? You should post in the Rom's thread and ask..If so you know your answer..

Another thing you can try is swapping some system files.. Post back here if no one else has the issue..
1st August 2014, 04:43 PM   |  #3  
AceZ71's Avatar
Member
Thanks Meter: 23
 
42 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by kmasterz

Hey guys, I've had this problem ever since android 4.3, had it on 4.4.2, and after trying liquidsmooth's 4.4.4, the problem still exists. Wifi keeps dropping to LTE, and if I try to toggle wifi back on, the toggle switch "hangs" for a moment on the "on" switch while greyed out, and then automatically switches back to the "off" switch. Only after some time passes, sometimes taking several days, does the wifi randomly switch back on. Does anybody else have had to deal with this problem? And how were you able to resolve it? Thanks in advance

Sounds like you haven't flashed the MJ9 firmware. It can be found here http://forum.xda-developers.com/show....php?t=2578458

Edit: Here's a more detailed post http://forum.xda-developers.com/show...php?p=50047714


Sent from my SCH-I605
Last edited by AceZ71; 1st August 2014 at 04:48 PM.
2nd August 2014, 01:13 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Dec 2010
Thanks guys I went back to 4.1.2 and reflashed my way up through 4.3 to 4.4.2 to cm11. Hopefully this will clear up my Wi-Fi issue, will report back if the toggling issue persists

Sent from my SCH-I605 using XDA Free mobile app

*never mind, wifi dropped within an hour of installing cm11 4.4.4. Any suggestions would be much appreciated.

- to Acez71: I flashed MJ9 firmware, still no go
- to lacoursiere18: The problem still exists on CM11, I'm beginning to think the problem isn't ROM specific
Last edited by kmasterz; 2nd August 2014 at 02:22 AM. Reason: updates on situation
8th August 2014, 01:35 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Dec 2010
Update: it seems my issue was hardware related, specifically the two gold contacts inside the cover and the two points on the back of the phone weren't making good contact. After cleaning the points and securing the cover firmly my WiFi issues seem to have disappeared for now. So if any of you are having similar issues, make sure to check the WiFi antenna contacts on the back of the phone
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes