Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,781 Members 47,085 Now Online
XDA Developers Android and Mobile Development Forum

[Q] problem toggling wifi

Tip us?
 
kmasterz
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2010
Question [Q] problem toggling wifi

Hey guys, I've had this problem ever since android 4.3, had it on 4.4.2, and after trying liquidsmooth's 4.4.4, the problem still exists. Wifi keeps dropping to LTE, and if I try to toggle wifi back on, the toggle switch "hangs" for a moment on the "on" switch while greyed out, and then automatically switches back to the "off" switch. Only after some time passes, sometimes taking several days, does the wifi randomly switch back on. Does anybody else have had to deal with this problem? And how were you able to resolve it? Thanks in advance
 
lacoursiere18
Old
#2  
lacoursiere18's Avatar
Recognized Themer
Thanks Meter 4,256
Posts: 3,179
Join Date: Jan 2013
Location: LbTs

 
DONATE TO ME
Quote:
Originally Posted by kmasterz View Post
Hey guys, I've had this problem ever since android 4.3, had it on 4.4.2, and after trying liquidsmooth's 4.4.4, the problem still exists. Wifi keeps dropping to LTE, and if I try to toggle wifi back on, the toggle switch "hangs" for a moment on the "on" switch while greyed out, and then automatically switches back to the "off" switch. Only after some time passes, sometimes taking several days, does the wifi randomly switch back on. Does anybody else have had to deal with this problem? And how were you able to resolve it? Thanks in advance
Hmm sounds like a Rom problem. Does anyone else installing Liquid Smooth have that issue? You should post in the Rom's thread and ask..If so you know your answer..

Another thing you can try is swapping some system files.. Post back here if no one else has the issue..

Hit "Thanks" if I helped you
 
AceZ71
Old
(Last edited by AceZ71; 1st August 2014 at 03:48 PM.)
#3  
AceZ71's Avatar
Junior Member
Thanks Meter 3
Posts: 25
Join Date: Jan 2011
Quote:
Originally Posted by kmasterz View Post
Hey guys, I've had this problem ever since android 4.3, had it on 4.4.2, and after trying liquidsmooth's 4.4.4, the problem still exists. Wifi keeps dropping to LTE, and if I try to toggle wifi back on, the toggle switch "hangs" for a moment on the "on" switch while greyed out, and then automatically switches back to the "off" switch. Only after some time passes, sometimes taking several days, does the wifi randomly switch back on. Does anybody else have had to deal with this problem? And how were you able to resolve it? Thanks in advance
Sounds like you haven't flashed the MJ9 firmware. It can be found here http://forum.xda-developers.com/show....php?t=2578458

Edit: Here's a more detailed post http://forum.xda-developers.com/show...php?p=50047714


Sent from my SCH-I605
 
kmasterz
Old
(Last edited by kmasterz; 2nd August 2014 at 01:22 AM.) Reason: updates on situation
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2010
Thanks guys I went back to 4.1.2 and reflashed my way up through 4.3 to 4.4.2 to cm11. Hopefully this will clear up my Wi-Fi issue, will report back if the toggling issue persists

Sent from my SCH-I605 using XDA Free mobile app

*never mind, wifi dropped within an hour of installing cm11 4.4.4. Any suggestions would be much appreciated.

- to Acez71: I flashed MJ9 firmware, still no go
- to lacoursiere18: The problem still exists on CM11, I'm beginning to think the problem isn't ROM specific
 
kmasterz
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2010
Update: it seems my issue was hardware related, specifically the two gold contacts inside the cover and the two points on the back of the phone weren't making good contact. After cleaning the points and securing the cover firmly my WiFi issues seem to have disappeared for now. So if any of you are having similar issues, make sure to check the WiFi antenna contacts on the back of the phone
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes