Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,955 Members 52,890 Now Online
XDA Developers Android and Mobile Development Forum

PSA: S Voice stops working in VoLTE markets using the "phone" APN

Tip us?
 
BarryH_GEG
Old
#1  
BarryH_GEG's Avatar
Senior Member - OP
Thanks Meter 4,172
Posts: 8,693
Join Date: Jan 2009
Location: Spokane, Washington
Default PSA: S Voice stops working in VoLTE markets using the "phone" APN

I found out I was in a VoLTE market a couple of months ago when I was using the MLG 4.4 link and AT&T's "nxtgenphone" APN worked. Official 4.4 used the phone APN and I left it alone. About a week ago S Voice stopped working when I was using AT&T data but continued working fine over Wi-Fi. I pulled my hair out resetting S Voice and trying different versions; even the one from the SGS5. It still wouldn't work. I manually input the nxtgenphone APN and it started working again. So if you're having trouble with S Voice and are in a VoLTE market you might want to change/update your APN.
The Following 2 Users Say Thank You to BarryH_GEG For This Useful Post: [ Click to Expand ]
 
raiu
Old
#2  
raiu's Avatar
Senior Member
Thanks Meter 85
Posts: 384
Join Date: Oct 2008

 
DONATE TO ME
Quote:
Originally Posted by BarryH_GEG View Post
I found out I was in a VoLTE market a couple of months ago when I was using the MLG 4.4 link and AT&T's "nxtgenphone" APN worked. Official 4.4 used the phone APN and I left it alone. About a week ago S Voice stopped working when I was using AT&T data but continued working fine over Wi-Fi. I pulled my hair out resetting S Voice and trying different versions; even the one from the SGS5. It still wouldn't work. I manually input the nxtgenphone APN and it started working again. So if you're having trouble with S Voice and are in a VoLTE market you might want to change/update your APN.
im betting that is what my issue is, can you give me the settings so I can make this apn?
**Remember to give thanks every day your device works **
 
BarryH_GEG
Old
#3  
BarryH_GEG's Avatar
Senior Member - OP
Thanks Meter 4,172
Posts: 8,693
Join Date: Jan 2009
Location: Spokane, Washington
Quote:
Originally Posted by BarryH_GEG View Post
I found out I was in a VoLTE market a couple of months ago when I was using the MLG 4.4 leak and AT&T's "nxtgenphone" APN worked. Official 4.4 used the phone APN and I left it alone. About a week ago S Voice stopped working when I was using AT&T data but continued working fine over Wi-Fi. I pulled my hair out resetting S Voice and trying different versions; even the one from the SGS5. It still wouldn't work. I manually input the nxtgenphone APN and it started working again. So if you're having trouble with S Voice and are in a VoLTE market you might want to change/update your APN.
EDIT

Here's the Nxtgenphone APN...




I was just out of town in a non-VoLTE market and had to go back to the phone APN. When I got home, I changed to the nextgenphone APN but S Voice wouldn't work again. I have a Gear and I had to completely reset it along with removing Gear Manager in order to get S Voice working again. So whatever's trashing S Voice may have something to do with the Gear, VoLTE, or both. Not having S Voice on your phone over AT&T's data lines (vs. WiFi) pretty much renders the Gear useless. Do any of you having issues also have a Gear running off your phone?
 
raiu
Old
#4  
raiu's Avatar
Senior Member
Thanks Meter 85
Posts: 384
Join Date: Oct 2008

 
DONATE TO ME
Quote:
Originally Posted by BarryH_GEG View Post
EDIT

Here's the Nxtgenphone APN...




I was just out of town in a non-VoLTE market and had to go back to the phone APN. When I got home, I changed to the nextgenphone APN but S Voice wouldn't work again. I have a Gear and I had to completely reset it along with removing Gear Manager in order to get S Voice working again. So whatever's trashing S Voice may have something to do with the Gear, VoLTE, or both. Not having S Voice on your phone over AT&T's data lines (vs. WiFi) pretty much renders the Gear useless. Do any of you having issues also have a Gear running off your phone?
Yes. This is what started me on his quest lol. My s voice has been working and then quit which rendered the watch pointless. So I have been trying to fix it for a few days now
**Remember to give thanks every day your device works **
 
raiu
Old
#5  
raiu's Avatar
Senior Member
Thanks Meter 85
Posts: 384
Join Date: Oct 2008

 
DONATE TO ME
I did download the update from here for Svoice,

http://www.sammobile.com/2014/03/24/...the-galaxy-s5/

That seemed to help a bunch with the Svoice issues. But my phone still gets kicked off LTE and stuck at 4g where others that use ATT still show LTE. I can restart my phone and I will then have LTE service.
**Remember to give thanks every day your device works **
 
BarryH_GEG
Old
#6  
BarryH_GEG's Avatar
Senior Member - OP
Thanks Meter 4,172
Posts: 8,693
Join Date: Jan 2009
Location: Spokane, Washington
Quote:
Originally Posted by raiu View Post
I did download the update from here for Svoice,

http://www.sammobile.com/2014/03/24/...the-galaxy-s5/

That seemed to help a bunch with the Svoice issues. But my phone still gets kicked off LTE and stuck at 4g where others that use ATT still show LTE. I can restart my phone and I will then have LTE service.
It's an odd problem and not easy to isolate. When S Voice first died I thought it was related to the S Voice app itself. I tried the SGS5 update in your link right before the problem started and thought that was it. So I cleared data in the app via Settings and went back to the factory version and the N3-specific S Voice update that came out a few months ago. Didn't solve the problem - S Voice was fine over Wi-Fi but borked on AT&T data.

I remembered I was in a VoLTE market and tried the nxtgenphone APN and that solved the problem. All three versions of S Voice worked; original, N3 update, and SGS5 update. Everything was fine until I had to use the "phone" APN in a non-VoLTE market. S Voice worked fine until I got home to my VoLTE market and it stopped working again. This time, the nxtgenphone APN didn't help. I cleared data on S Voice again and tried all three versions and S Voice still wouldn't work.

Thinking it might be Gear related I deleted the Gear from BT settings, uninstalled Gear Manager from my phone, hard reset my Gear by long pressing the power button and using recovery, and rebuilding it via reset rather than using "restore" to reinstall my previous apps/settings. For some reason, the original and N3 update of S Voice wouldn't work. The SGS5 version did. At some point in the second "S Voice is broken" repair S Voice started to work on my phone but not the Gear.

So some combination of playing with the APN's, installing different versions of S Voice, and resetting the Gear, S Voice is working reliably again. What a pain in the ass. I'm guessing it's AT&T network related because its the only common denominator in both times S Voice started to fail and using the nxtgenphone APN fixed it the first time.
 
Avi-J
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
Default Same issue here (Samsung Note 3), ATT & Samsung are clueless

There is a significant amount of discussion of this issue in the att forums (I can't post links, but it's at https : // forums.att.com/t5/Android/S-Voice-now-Voice-talk-and-non-Wi-Fi-connection/m-p/4053580#M53935). I've been experiencing this for about four days now. S-Voice suddenly stopped working and returned "I can't find a network connection. Please connect to network and try again." This only happens on the AT&T data network; wi-fi works fine. When I called AT&T tech support last night, they actually knew about this issue but had nothing to offer me beyond the fact that it was a "known issue" and that "Samsung is working on a solution." They gave me the number for Samsung tech support, but those folks were less than helpful. At first, they pretended it was an issue with my phone and said I should send it in for repair. He said that there were no other reports of this issue from other users.

Then, when I mentioned that this issue is all over the Internet, the guy said "Well, we have had a 'significant' number of complaints about this, but not a high number." Every time I asked a question ("Do you have an SLA for a resolution?"), he put me on hold for five minutes and came back and asked irrelevant questions. ("So, you say this happened because of a software update?" "No, YOU said that.")

Finally, he said it was an Android issue and that Google is working on a fix.

I have downloaded the S5 version of S-Voice: apart from the ugly colors, it behaves exactly the same as the Note 3 version (i.e, works on wifi and does not work on the mobile network). I also tried changing the APN per the screenshot in this thread, but that did not change the situation.

As a workaround, I'm currently using "S for Switch Voice" (a buggy little app that switches to Google Search every time S-Voice is opened), but I'm really hoping this is fixed soon. Right now, all I'm seeing is finger pointing.
 
raiu
Old
#8  
raiu's Avatar
Senior Member
Thanks Meter 85
Posts: 384
Join Date: Oct 2008

 
DONATE TO ME
Quote:
Originally Posted by Avi-J View Post
There is a significant amount of discussion of this issue in the att forums (I can't post links, but it's at https : // forums.att.com/t5/Android/S-Voice-now-Voice-talk-and-non-Wi-Fi-connection/m-p/4053580#M53935). I've been experiencing this for about four days now. S-Voice suddenly stopped working and returned "I can't find a network connection. Please connect to network and try again." This only happens on the AT&T data network; wi-fi works fine. When I called AT&T tech support last night, they actually knew about this issue but had nothing to offer me beyond the fact that it was a "known issue" and that "Samsung is working on a solution." They gave me the number for Samsung tech support, but those folks were less than helpful. At first, they pretended it was an issue with my phone and said I should send it in for repair. He said that there were no other reports of this issue from other users.

Then, when I mentioned that this issue is all over the Internet, the guy said "Well, we have had a 'significant' number of complaints about this, but not a high number." Every time I asked a question ("Do you have an SLA for a resolution?"), he put me on hold for five minutes and came back and asked irrelevant questions. ("So, you say this happened because of a software update?" "No, YOU said that.")

Finally, he said it was an Android issue and that Google is working on a fix.

I have downloaded the S5 version of S-Voice: apart from the ugly colors, it behaves exactly the same as the Note 3 version (i.e, works on wifi and does not work on the mobile network). I also tried changing the APN per the screenshot in this thread, but that did not change the situation.

As a workaround, I'm currently using "S for Switch Voice" (a buggy little app that switches to Google Search every time S-Voice is opened), but I'm really hoping this is fixed soon. Right now, all I'm seeing is finger pointing.
Unfortunately that doesn't work for us with the galaxy gear or gear 2. What ever happened has disabled the ability to use s voice on the gear and the ability to start calls using your voice.
**Remember to give thanks every day your device works **
 
BarryH_GEG
Old
#9  
BarryH_GEG's Avatar
Senior Member - OP
Thanks Meter 4,172
Posts: 8,693
Join Date: Jan 2009
Location: Spokane, Washington
Quote:
Originally Posted by raiu View Post
Unfortunately that doesn't work for us with the galaxy gear or gear 2. What ever happened has disabled the ability to use s voice on the gear and the ability to start calls using your voice.
Have you completely removed the Gear from your phone and reset it using recovery? That's what fixed it for me the second time I had the issue. It only works with the SGS5 version of S Voice though.
 
raiu
Old
#10  
raiu's Avatar
Senior Member
Thanks Meter 85
Posts: 384
Join Date: Oct 2008

 
DONATE TO ME
Quote:
Originally Posted by BarryH_GEG View Post
Have you completely removed the Gear from your phone and reset it using recovery? That's what fixed it for me the second time I had the issue. It only works with the SGS5 version of S Voice though.
mine works with the s5 svoice app update
**Remember to give thanks every day your device works **

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes