Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Gallery keeps crashing

OP Xaffin

13th July 2014, 01:57 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Apr 2013
So after rooting my phone, my gallery has been crashing every time I try to open it.

I rooted with this:
http://forum.xda-developers.com/show....php?t=2709701

I tried clearing the data and clearing the cache and it didn't work.
I tried going in from my computer and copying out the data and deleting it so that I can restart with a new DCIM folder, but it's written protected... =/

Ideas anyone?
Last edited by Xaffin; 13th July 2014 at 02:38 AM.
13th July 2014, 02:27 AM   |  #2  
Junior Member
Thanks Meter: 3
 
4 posts
Join Date:Joined: Jul 2014
More
How do you mean password protected? Never seen that on an Android folder. Shouldnt you just remove this lock to help your app?
13th July 2014, 03:13 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by Uberharm

How do you mean password protected? Never seen that on an Android folder. Shouldnt you just remove this lock to help your app?

Sorry didn't mean to say password protected. I misspoke and meant to say written protection. I can't delete the files or edit it, but I can copy it.
13th July 2014, 01:16 PM   |  #4  
Junior Member
Thanks Meter: 3
 
4 posts
Join Date:Joined: Jul 2014
More
Ok So it's slightly different from flashing a phone like my galaxy S2 I9100.
On my phone I should flash a ROM and a .zip package of gapps (google apps) among which is the gallery app.
Since you don't have to flash such a package I wonder whether you came from a KK ROM.

You said you rooted it like this. So I assume you came from stock KK ROM which comes with your AT&T Note 3, which should be no fine. But you can check that though.

Further ideas;
it could be a corrupt file somewhere on your device. You're gallery app will try to show it or make a thumbnail out of something which will result in a crash. For this you can try other gallery apps (I liked quickpic) and see if they crash.

Maybe you can unprotect the folder/files simply by:
http://www.ehow.com/how_5059293_rid-...tion-file.html

On this thread it appeared to be an old SD card so that could be the problem as well.
The Following User Says Thank You to Uberharm For This Useful Post: [ View ]
13th July 2014, 08:00 PM   |  #5  
OP Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by Uberharm

Ok So it's slightly different from flashing a phone like my galaxy S2 I9100.
On my phone I should flash a ROM and a .zip package of gapps (google apps) among which is the gallery app.
Since you don't have to flash such a package I wonder whether you came from a KK ROM.

You said you rooted it like this. So I assume you came from stock KK ROM which comes with your AT&T Note 3, which should be no fine. But you can check that though.

Further ideas;
it could be a corrupt file somewhere on your device. You're gallery app will try to show it or make a thumbnail out of something which will result in a crash. For this you can try other gallery apps (I liked quickpic) and see if they crash.

Maybe you can unprotect the folder/files simply by:
http://www.ehow.com/how_5059293_rid-...tion-file.html

On this thread it appeared to be an old SD card so that could be the problem as well.

Lol sorry for the misunderstanding. Just to clarify, yes I flashed it with the KK ROM: http://forum.xda-developers.com/show....php?t=2709701
and rooted with this: http://forum.xda-developers.com/show....php?t=2783157

Yeah I've tried to unprotect it, but the options were grayed out. It won't let me click on them or unclick them.

When I access my DCIM folder it looks like this. The folder would contain my pictures and a bunch of other files that I don't recognize. I'm not sure whether it was from the ROM or the root.....

and with Quickpic it worked... ish~ I was able to open the app with a long loading time...and it also contains the other files that I don't recognize as well....
Attached Thumbnails
Click image for larger version

Name:	1.jpg
Views:	12
Size:	185.4 KB
ID:	2849379  
13th July 2014, 08:46 PM   |  #6  
OP Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Apr 2013
ugh i ended up just reformatting my SD card, i just wanted to get rid of the problem.

oh well. thanks for the help really appreciate it.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes