Thumbs down [Q] Stuck in a loop with shield.

So basically when I bought my shield it worked perfectly out of the box, here is the specs...
3570k i5
780ti
Pce ASUS ac68
Asus ac68u router

As I said it worked flawlessly, no latency issues etc. Then round about the same time the KitKat update rolled out, and GeForce experience 2.1 dropped. This immediately ruined streaming. Would say PC was offline and Gfe wouldn't allow new connections to it. Shield couldn't find the PC on the network when looking for a new streaming connection. I'm told too that the KitKat update broke a lot of the emulators (essentially bricking the shield to be honest).
I ripped out all the Nvidia software and downgraded to 2.0 GeForce experience which is bundled with an older version of the GPU drivers. Also unlocked, rooted and flashed the shield back to factory android version. This meant I could stream again without issue, great!!!

Now I've bought a shield wireless controller to play games on the sofa in console mode. Problem now is that you need the shield wireless controller app on the shield to connect, this only comes with the latest android update, which only works with gfe 2.1 which subsequently breaks the streaming. So either I have a working shield running old software that I cant connect the controller to, or I have everything up to date and a controller connected but lose the ability to play games. How very very stupid.

What do I do to get the best of both worlds? The wireless controller app isn't available on play store or anywhere else. Can anyone get the standalone apk?! Need help.

Thanks!!