Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,088 Members 39,094 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Files/Firmware backup request

Tip us?
 
Snackiz
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jun 2014
Unhappy [Q] Files/Firmware backup request

Hi,
I seem to have destroyed some things in my /system partition, and since I'm too stupid to make a backup before I edit a single file, I could really need your help.

The version I currently have installed is the one with the following values in the files:

/custom_build_verno:
20140513.163904

/system/build.prop:
ro.adups.fota.version=TrueSmart-20140513-1040

As far as I know right now, the following files are being complained about in the boot loop that I'm currently stuck in:

E/linker (25065): load_library(linker.cpp:757): library "/system/lib/libnetcmdiface.so" not found
E/linker (25064): load_library(linker.cpp:757): library "/system/lib/soundfx/libloudnesswrapper_mtk.so" not found

Can someone check if they are available in their TrueSmart or if this is a red herring and this file is not available at all?
 
Snackiz
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jun 2014
The missing files are not available in the firmware found in these forums with the file name Omate_TrueSmart_20140513.103530_V2.0.zip

Can anyone verify in their logcat that they are also getting these missing file errors on a working TrueSmart?
 
MrTip
Old
#3  
MrTip's Avatar
Member
Thanks Meter 4
Posts: 55
Join Date: Jun 2014
Quote:
Originally Posted by Snackiz View Post
E/linker (25065): load_library(linker.cpp:757): library "/system/lib/libnetcmdiface.so" not found
E/linker (25064): load_library(linker.cpp:757): library "/system/lib/soundfx/libloudnesswrapper_mtk.so" not found
Hi, I clearly remember seeing these 2 error when I messed up with my TS. (I did many things, not sure what caused this)
I finally managed to go back to stock with "sp flash tools".
TS 1/8/2100
 
  • Hardware : MT6572
  • Model : TrueSmart
  • Build number : ALPS.JB3.MP.V1.8
  • Build date UTC : 20140513-024041
  • Android v : 4.2.2
  • Baseband v: MOLY.WR8.W1315.MD.WG.MP.V4, 2013/08/14 18:16


LG G3 D855
 
  • ro.build.description: g3_global_com-user 4.4.2 KVT49L.A1404795316 1404795316 release-keys
  • ro.build.target_country: EU
  • ro.build.version.release: 4.4.2
 
Snackiz
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jun 2014
Quote:
Originally Posted by MrTip View Post
Hi, I clearly remember seeing these 2 error when I messed up with my TS. (I did many things, not sure what caused this)
I finally managed to go back to stock with "sp flash tools".
Thanks. I flashed the system partition and it's working fine now.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes