Post Reply

[Q] Microphone issues during calls (512/4 KS dev.ed.)

OP Holy Bear

24th August 2014, 01:14 PM   |  #1  
Holy Bear's Avatar
OP Senior Member
Flag Utrecht
Thanks Meter: 0
 
129 posts
Join Date:Joined: Apr 2006
More
I received a TrueSmart yesterday (bought it off a KS backer) that "never had any problems".
I can say that so far, most functions work as I would need them to (Bluetooth, WiFi, 3G, GPS, etc.) and I'm not really interested in those I have not tested (waterproof I simply assume it is not, for example).

There is, however, one thing that is absolutely horrendous, and that's call quality through the TS microphone (so not bluetooth). My friend says she'd rather not call me at all as it is unbearable. Specifically, when I am not speaking there's a "whoosh"ing sound at regular intervals, which recedes when I am speaking but my voice then sounds almost garbled. There is also an unacceptable amount of echo.

Now, when using the voice record app, there is no problem whatsoever with the microphone. Which imho means that it cannot be a hardware fault.

I'm hoping someone here can enlighten me:
- Could it be that this problem is based on ineffectual Audio Echo Cancellation in the software? (to me, that would explain the feedback-like periodical whoosh and the echo)
- Is there any chance whatsoever that this issue could be resolved on my device?



Edited to add some more info:
- Kernel 3.4.5
- OUI 2.0
- 20140706-V2.0
Last edited by Holy Bear; 24th August 2014 at 01:16 PM.
24th August 2014, 03:10 PM   |  #2  
Senior Member
Thanks Meter: 50
 
147 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by Holy Bear

I received a TrueSmart yesterday (bought it off a KS backer) that "never had any problems".
I can say that so far, most functions work as I would need them to (Bluetooth, WiFi, 3G, GPS, etc.) and I'm not really interested in those I have not tested (waterproof I simply assume it is not, for example).

There is, however, one thing that is absolutely horrendous, and that's call quality through the TS microphone (so not bluetooth). My friend says she'd rather not call me at all as it is unbearable. Specifically, when I am not speaking there's a "whoosh"ing sound at regular intervals, which recedes when I am speaking but my voice then sounds almost garbled. There is also an unacceptable amount of echo.

Now, when using the voice record app, there is no problem whatsoever with the microphone. Which imho means that it cannot be a hardware fault.

I'm hoping someone here can enlighten me:
- Could it be that this problem is based on ineffectual Audio Echo Cancellation in the software? (to me, that would explain the feedback-like periodical whoosh and the echo)
- Is there any chance whatsoever that this issue could be resolved on my device?



Edited to add some more info:
- Kernel 3.4.5
- OUI 2.0
- 20140706-V2.0

Supposedly the 512/4 batch had both SW and HW problems, being better on 1/8.
20140706 oui2.0 seems like a strange combination, from April and forward it should be oui2.1 (not that that oui matters, but there may be firmware fixes...)
24th August 2014, 03:18 PM   |  #3  
Holy Bear's Avatar
OP Senior Member
Flag Utrecht
Thanks Meter: 0
 
129 posts
Join Date:Joined: Apr 2006
More
Quote:
Originally Posted by gerhardo

20140706 oui2.0 seems like a strange combination, from April and forward it should be oui2.1 (not that that oui matters, but there may be firmware fixes...)

Ooops, my bad: OUI 2.1
3rd October 2014, 06:40 PM   |  #4  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2014
I too purchased an Omate Truesmart 1/8 1900 from a seller on Swappa, and all of the people I have talked to using the built-in Speakerphone and mic have stated that I am extremely muffled and they cannot understand me. The Google Search voice recognition works fine, and voice to text works fine as well. Was there ever a resolution to this problem?
5th October 2014, 09:59 PM   |  #5  
Holy Bear's Avatar
OP Senior Member
Flag Utrecht
Thanks Meter: 0
 
129 posts
Join Date:Joined: Apr 2006
More
Quote:
Originally Posted by tim2lman

I too purchased an Omate Truesmart 1/8 1900 from a seller on Swappa, and all of the people I have talked to using the built-in Speakerphone and mic have stated that I am extremely muffled and they cannot understand me. The Google Search voice recognition works fine, and voice to text works fine as well. Was there ever a resolution to this problem?

Not on my end.
Post Reply Subscribe to Thread

Tags
in-call sound problem, microphone, omate, truesmart
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes